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Introduction
MOLQUEST is the most comprehensive, easy-to-use desktop application sequence analysis and 
molecular  biology  data  management  available  in  the  market  today.  The  package  includes 
versatile family of genefinders, FGENESH/H+, with parameters for wide variety of genomes, as 
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well  as  pipelines  for  fully  automatic  annotation  of  eukaryotic  (FGENESH++)  and  bacterial 
(FGENESB) genomes,  which proved to be the most  accurate  genefinding tools overall  (see 
here).
The package has a user-friendly interface for sequence editing, primer design, internet database 
searches,  gene  prediction,  promoter  identification,  regulatory  elements  mapping,  patterns 
discovery protein analysis, multiple sequence alignment, phylogenetic tree  reconstruction, and a 
wide variety of other functions. 

Product information: softberry@softberry.com 

MolQuest Technical Support: support@molquest.com

Fundamental Definitions

Program
MolQuest  integrates  various  programs  for  molecular  biology  data  processing.  Programs  are 
distributed by their developers in packages. Packages are installed by the main menu command 
Tools -> Install Package. All available programs are displayed in Programs List of the Toolbox 
Tab.) 

Task 
In  MolQuest,  a  task  is  a  command to  run a  program using certain  values  of  its  parameters 
(properties). Same program with two different sets of values of its parameters is considered to 
represent  two  different  tasks.  Current  status  of  a  task  (being  processed,  finished,  ready)  is 
displayed  in Project Tab. 

Project 
Project is the key element and executable unit of MolQuest workflow, consisting of an ordered 
set of tasks, defined by user. For each new project, MolQuest creates a separate folder. That 
folder contains subfolders corresponding to each of a project's task, where those tasks' outputs 
are written and can be accessed by user. A list of a project's tasks is shown in Project Tab and 
Pipeline tab. While executing a project, only tasks with status Enabled are executed (see  Task 
Status).

Pipeline 
An output of a task can be as an input for another task, which creates a sequential order of tasks, 
called  pipeline.  The  Pipeline  Tab displays  all  links  between  tasks  in  a  pipeline.  Predefined 
pipelines from packages are shown in Pipelines List of Toolbox Tab

View 
Quite often, users run the same program with varied values of program's parameters (properties). 
Each set Program + Properties can be specified as a separate task: for instance, program P with 
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several different sets of parameters can be defined as several separate tasks, T1, T2 etc. In many 
cases, however, an alternative approach, which uses MolQuest's concept called View, is more 
convenient. View is a set of parameters values within a task, so that instead of separate tasks as 
above we get a set of separate views, V1, V2 etc. Each task has at least one view, Current View, 
which is used when task is executed. Each of existing views within a task can be set as Current 
View, which is done when user wants to run a task with a different set of values of program's 
parameters. 

User can not only set parameters to different values, but also hide non-essential parameters from 
being shown  Properties Tab.  For instance,  user can take view V1 and hide all  non-essential 
parameters, creating view V2 – identical in all respects except visual representation of parameter 
values. This is useful in case of multi-parameter tasks, when only few parameters are varied, 
while the majority remain the same and are hidden from view in order not to distract user. 

Converter 
In most cases of pipeline-like queues of tasks, an output of one task, supposed to be used as an 
input of another task, has format that is incompatible with «downstream» task. To convert an 
output to format suitable for another program, special auxilliary programs, called converters, are 
used. In many cases, MolQuest can automatically add an appropriate converter to a pipeline. As 
most programs, converters are distributed in packages. The Converters List in the Toolbox Tab 
shows all available converters. 

Getting Started 
As we now know, in order to execute even a single task, user has to create and run a project. 
Here we discuss how to work with projects, specifically: 

1. Create/open a project  . 
2. Add tasks to the project.   
3. Define task properties.   
4. Enable tasks.   
5. Run the project  . 
6. View results   

The user also may create pipelines

Create/open a project 
To open an existent  project,  choose File->Open Project  in the main  menu.  Then choose the 
project’s folder.

To create a new project, use File->New Project in the main menu. In the "Create new Project" 
dialog, enter folder name for a new project. It will also be assigned as a name of a project itself. 
If you want to change the location of the project folder, press Browse button. If the project folder 
already exists in the current location or contains invalid symbols, the "OK" button in the "Create 
new Project" dialog will be inactive. The project name is shown on top of the Project Panel. You 
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can change the name, it does not have to match the folder name or be unique. Press the "OK" 
button to confirm. A new project with the specified name has now been created.  

Add tasks to the project. 
Choose a program group in  Toolbox and double click to a program to append it to a list in 
Project Tab. Generally,  the task is not yet  ready and cannot be enabled unless its mandatory 
parameters  (also called properties)  are assigned values – for instance,  FGENESH cannot run 
unless  genefinding  matrix  (human,  monocot  plants  etc.)  is  specified.  Project  tasks  are  also 
displayed in Pipeline tab.

Define task properties 
The properties (parameter values) of a task can be edited in  Property Editor of  Properties tab. 
Before a task can be executed, you must set values to all necessary parameters. If a mandatory 
parameter is not set or its value is wrong, MolQuest highlights it with red color and “!”  mark, 
like this:

Enable a task 
Since only enabled tasks are executed during the project, a task scheduled for execution should 
be enabled first. To enable a task, do one of the following: 

• Use the Task->Enable Task command on the Main Menu 

• In the list of project tasks, tick the check box  in the "Status" field. 

• Press the  button. This enables all tasks within a project that are in "Ready" status. 

Only tasks that are in "Ready" status can be enabled (see Task Status).

Run a project 
When a project is run, its tasks are executed one by one in the same order as they appear in the 
list of project tasks, from top to bottom (Project Tab ). A user can, at any time, change an order 
in which tasks are executed. To change an order, use Task->Move Up and Task->Move Down 

commands of the Main Menu or   and  buttons. 

To run a project, do one of the following: 

• use the Run->Run Project command on the Main Menu 

• Press the  button on the Toolbar. 

If you want to execute only one task of a project, select the task at the Project Tab or the Pipeline 

tab.and click   If you run a single task rather than a project, that task can have not only status 
“Enabled”, but also “Ready”.
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When a task is being run, its status is “In Progress” (see Task Status).

Completed tasks have status “Completed” (see Task Status).

If  an  error  occurred  during  the  execution  of  a  task,  the  task  gets  either  "Completed  with 

Warnings!" or "Completed with ERROR!" status (see Task Status). 

Interrupting execution of a project or a task
To interrupt execution of a project, do one of the following: 

• Press the  button or use Run->Stop Project command in the Main Menu. This stops 
the execution of a project immediately after completion of any task pass that is currently 
running. 

• Press the   button or use  Run->Abort Project command in the Main Menu. This 
aborts a task currently running and stops the execution of a project immediately. 

To interrupt the execution of a task, do one of the following: 

• Press the  or use Task->Stop Task command in the Main Menu. Stops the execution 
of a task immediately after completion of a pass that is in progress.

• Press the  button or use the Task->Abort Task command on the Main menu. Aborts 
a task immediately. 

If you interrupt a task, a project continues running, the next task in a queue being executed, 

unless you run a single task by pressing a  button (see above).

Viewing results
Executed task assumes one of three states: 

"Completed" – Normal completion, output was created

“Completed  with  Warnings”  –  Output  was  created,  but  may  be  wrong:  user  should  check 
warnings.

“Completed with Errors” – Output may be missing. Even if it exists, it is wrong. 

An  output  of  a  task  can  be  viewed  in  Project  Tab (column  “Results”),  Results  Tab or 
View/Console Tab.

Create pipelines 
A project may consist of a complex sequence of tasks, where an output of one task is used as an 
input for another. Such kind of project is called a pipeline. 
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There are two ways of making an output of one task an input of another task:  You can use either 
Property Editor or Pipeline tab. 

In Property Editor, choose "Pipe" type for required input source. The  button appears which, 
when pressed, displays "Select Task Output" dialog listing outputs of all project’s tasks that can 
potentially be used as inputs. 

Alternatively, you can use Pipeline tab, which displays MolQuest projects as block diagrams in 
user-editable form. Here, to create a pipeline, connect output and input of corresponding tasks 
with a mouse: click on an output of a task, and a cursor takes this form: 

, now move a cursor to an input area of a “downstream” task. Yellow line will follow a 

cursor there. If two tasks cannot be linked in a pipeline, a cursor transforms into this icon: . 

If, however, link is possible, it will look like this: . Click on an input area, and two tasks are 
linked into pipeline relationship. Similarly, you can start with an input field of a downstream task 

and move to output field of an upstream task. In such case, cursor will assume this look:  . 
If output and input formats of tasks are compatible, a pipeline link between them looks as a solid 

gray line: . If formats are incompatible, but a correspondent converter is registered with 
MolQuest, a link looks like a dotted gray line: . Finally, if formats are incompatible 

and there is no converter available, it looks as a black line: . 
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Interface

Application window

 1. Toolbox tab. 2. Repository tab. 3. Manager tab. 4. Status bar. 5. Main menu. 6. Toolbar. 7. Project tab. 
8. Pipeline tab. 9. View/Console tab. 10. Task tab. 11. To-Do tab. 12. Properties tab. 13. Results tab. 

Menus of application window
Main window has the following pull-down menus:

• File   
• Task   
• Project   
• Tools   
• Window   
• Help   

File

• New Project: Create a new project. In "Create New Project" dialog, enter folder name for 
a new project. It will also be assigned as a name of a project itself. If you want to change 
the location of the project folder, press Browse button. If the project folder already exists 



in  the current  location  or  contains  invalid  symbols,  the "OK" button in  "Create  new 
Project" dialog will be inactive. The project name is shown on top of the Project Panel. 
You can change the name, it does not have to match folder name or be unique. Press the 
"OK" button to confirm. A new project with the specified name has now been created. 

• Open  Project  -  Open  an  existing  project.  Displays  "Open  project"  dialog.  Choose  a 
project  folder and press the "Choose" button.  The project  is  now assigned a “current 
project” status. Project Tab and Pipeline Tab display tasks of current project.

• Reopen Project - Reopens current project without saving any changes made during the 
session. 

• Save All - Save all projects in their current state. 
• Save Project - Save current in its current state. 
• Save project as - This command is used to create a copy of the current project. All tasks 

and their properties are copied, while outputs/results  are not. Completed tasks change 
their status to “ready”, states of other tasks are unaffected. A dialog "Save project As" is 
displayed.  Type a unique name of a project  copy.  If name already exists  or contains 
invalid symbols, the "OK" button in the "Create Project" dialog will be inactive. Valid 
symbols are same as for Windows filenames.  Press the "OK" button to confirm.  The 
copied project is now the current project.
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• Close Project - Close current project. The project is saved at its current stage of progress 
and then closed. 

• Close All Projects -  Close all projects. The projects are saved at its current stage of 
progress and then closed. 

• Load Projects List  – Load projects from previously saved projects list. These projects 
are appended to a list of open projects (see below). 

• Save Projects List – Save a list of open projects. This list is also shown in Manager Tab.
• Close  Project  without  saving -  Close  current  project  without  saving.  Any  unsaved 

changes will be lost.
• Close All Projects without saving - Close All Projects without saving.
• Exit  without  projects  saving -  Close  All  Projects  without  saving  and  exit  the 

application. 
• Exit - Save all projects in their current state and exit the application. 

Task

• Run Task – run Selected Task. Task status must be Ready or Enabled
• Stop Task – stop execution of selected running task. If a task has several passes, it stops 

after current pass is copleted. This command does not stop the execution of a project. 
Other enabled tasks, if any, will be executed.

• Abort Task – immediately abort a task. This command does not stop the execution of a 
project. Other enabled tasks, if any, will be executed.

• Enable Task – enable a task. Only enabled task are run when a project is executed. 
• Disable Task – change task status from Enabled to Ready. 
• Move Up – move selected task one position up in a list of project tasks. 
• Move Down – move a task one position down. 
• Copy Task – create a copy of selected task and its properties.  Results/output are not 

copied. 
• Open Task Folder – open a folder with task output files. 
• Delete Results –delete results of selected task and resets its status to Ready. 
• Delete Task – delete a task and its results. 

Project
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• Rename Project - rename selected project. Displays "Rename Project" dialog. 

• Run Project - run a project. Only enabled tasks will run. 
• Stop Project - stop execution of a project immediately after a task pass in progress is 

completed.
• Abort Project – immediately abort execution of a project, not waiting until currently 

running pass is finished. 
• Enable All Ready Tasks - enable all tasks in current project. Only enabled tasks are run 

when a project is executed. 
• Disable All Enabled Tasks – change status of all enabled tasks to Ready.
• Delete All Results - delete results of all tasks within a project that have been completed.
• Clear Project - delete all tasks from current project. 
• Delete Project - delete current project. 

Tools

• Start With Selected Profile – If enabled, the last selected profile (see  Profile Manager 
dialog) is loaded when MolQuest is started. If disabled, MolQuest loads at start up the 
same configuration in had when exited. 

• Profile Manager - displays Profile Manager dialog for changing existing profile settings 
or creating new ones. 

• Options - Displays Options  dialog, which is used to control various MolQuest settings. 
• Panels Settings - displays Panels dialog.
• Property Editor Options – displays Property Editor Options dialog .
• Install Package - Displays "Install Package" dialog, used to install new programs and 

converters within MolQuest. Requires administrator privileges.

• Install License – install a new license. 

Window

• Style – sets interface window.
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• Toolbars – chooses toolbars to display (see Toolbars). 
• Screen Shot – choosing this menu option makes a shot of MolQuest screen, and a dialog 

for saving a screenshot is displayed. A shot is saved in png format. 

Help

• MolQuest Help – displays MolQuest help. 
• MolQuest License Agreement - displays MolQuest license agreement.
• Tutorials – submenu with a list of flash tutorials. 
• “Company” Main  Help -  displays  main  help  for  selected  company  (currently  only 

Softberry). 
• “Company” Help Files – submenu with all help files for selected company. 
• “Company” Sample Data – open a folder with sample data for selected company. 
• “Company” Sample Projects - displays "Sample Projects" dialog with list of premade 

sample projects for selected company. 

Choose program group and double  click  a  program to create  a  project  based on sample 
project. After choosing a project, "Save Sample Project As" dialog is displayed. See  Save 
Project As.
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• Softberry Home Page - opens Softberry home page. 
• MolQuest Home Page - opens MolQuest home page. 
• MolQuest Updates - opens MolQuest Updates page. 
• MolQuest Technical Support Page - opens MolQuest Technical Support page. 
• MolQuest Technical Support Mail - send an e-mail to MolQuest Technical Support. 
• About - displays "About" dialog. 

Toolbars
MolQuest has three toolbars: Project, View/Console, Configuration.

Project toolbar

Project Toolbar contains buttons for work with projects and tasks, which have the following 
functions: 

Same as: Project->Run Project in Main Menu 

Same as: Project->Stop Project in Main Menu 

Same as: Project->Abort Project in Main Menu 

Deletes all Tasks from Project 

Same as: Project->Delete All Results in Main Menu 

Same as: Project->Enable All Ready Tasks in Main Menu 

Same as: Project->Disable All Enabled Tasks in Main Menu 

Same as: Task->Open Task Folder in Main Menu 

Same as: Task->Copy Task in Main Menu 

Same as: Task->Delete Results in Main Menu 

Same as: Task->Delete Task in Main Menu 

Same as: Task->Run Task in Main Menu 

Same as: Task->Abort Task in Main Menu 

Same as: Task->Move Up in Main Menu 

Same as: Task->Move Down in Main Menu 

Evokes help cursor. Point it to a window object and click to get help. View/Console toolbar
View/Console toolbar has buttons for work with View/Console tab

Does  the  same  as  «Activate  View/Console»  in  dialog  Tools->Options-
>View/Console in Main Menu 
Same  as  «Show  Results»  in  dialog  Tools->Options->View/Console  in  Main 
Menu
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Same as «Show warnings» in dialog Tools->Options->View/Console in Main 
Menu
Same as «Show errors» in dialog Tools->Options->View/Console in Main Menu
Same as  «Console  Mode» in  dialog  Tools->Options->View/Console  in  Main 
Menu
Same as «Wrap by View Width» in dialog Tools->Options->View/Console in 
Main Menu
Same as «Column Selection Mode» in dialog Tools->Options->View/Console in 
Main Menu
Same as «Show Left Ruler» in dialog Tools->Options->View/Console in Main 
Menu
Same as «Show Top Ruler» in dialog Tools->Options->View/Console in Main 
Menu

Reopen current file in View/Console Configuration toolbar
Does the same as: Tools->Profile Manager in Main Menu
Chose profile from a list and make it current 

Toolbox tab
Toolbox tab is used to add a program or a converter to a project. The drop down list at the top of 
the tab contains the names of companies whose programs are included in MolQuest (currently 
only Softberry). 
The tab contains the following lists: 

Programs list. This list contains all included programs of a given company. To add a task 
to a project, expand appropriate group and double click on a program name. 

Converters  list. To  add  a  converter  to  a  project,  double  click  on  a  converter  name. 
Converters  are  special  programs  for  changing  file  formats.  Unlike  regular  programs, 
converters can be added to a project not only by user, but also automatically at pipeline level 
(see Pipeline Tab)

Pipelines list.  Contains  a  list  of  pipeline  template  projects.  To create  a  project  from a 
pipeline template, double click on a pipeline name. 
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1. List of distribution companies. 2.  List of programs. 3. List of converters. 4.List of 
pipelines.

Contextual menu of the "Toolbox" tab contains the following commands: 

  

• Auto Collapse  Groups – if  checked,  selecting  one program group collapses  all  other 
program groups. 

• Collapse All - collapse all program groups. 
• Expand All -  expand all  program groups.  If  "Auto Collapse"  mode  is  checked,  this 

option is inactive. 
• Program  (Converter,  Project)  Help -  open  help  for  selected  program  (converter, 

pipeline). 

Properties tab
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Properties tab is for setting up task properties (parameters). The Properties tab contains: 

• View List   
• Property Editor   
• Description page   
• Constrains page   

1. View List. 2. Property Editor  .   3. Description page. 4. Constrains page. 

 View List

View List contains a list of predefined task’s Views (see View). The contextual menu of View 
List is as follows:

• Add View Copy –  Create a copy of current view. Displays "Add View Copy" dialog, 
where user enters a name of a new View. 

16



• Rename View. Displays  "Rename View" dialog,  where user can change a name of a 
current View. 

• Delete View.
• Delete All Other Views. Deletes all Views except selected one.

 Property Editor.

Before executing a task, user has to specify all task’s properties (parameters), for instance type 
and location of an input, output options, and program options: for instance, organism-specific 
matrix  or  codon  table  for  FGENESH.  Some  tasks  have  several  dozens  of  properties  with 
complex dependencies. Any single property can be mandatory or optional. Some properties have 
default values. 
Property  Editor  handles  all  task  properties  in  a  convenient  way.  User  can  specify  strings, 
numbers, files, lists of files, folders and other types of data as property values. Every property 
has a value, and some values are incompatible with each other. Property Editor checks properties 
for such incompatibilities or other errors, as well as for omissions.  Properties can be nested (see 
example below).

Properties  are  grouped  in  sections,  which  vary  depending  on  program.  The  most  common 
sections are following:

• System - contains such informational properties as task name, program name and version 
etc. This section is mandatory, but filled automatically. 

• Input - includes various input properties, such as a source of input data (pipe, file, list of 
files etc.), definitions for detailed input (lists of variables or cases in SelTag) etc. 

• Output - includes various output properties, such as an output filename, its format, etc. 
• Options -  includes  various  task  properties,  such  as  processing  modes,  restrictions, 

coefficients etc.

 Property Icons and Property Activity 

Below is a window of Property Editor.
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Left column contains name of each property, right column – its value. Some of properties can 
have the following information icons next to their names: 

This is a system property, not defined by user. One such property is program name. 
The value for this property is undefined or wrong. 
This  node contains  one or more  nested properties,  for which the values are  undefined or 
wrong. 
This property is inactive and not used by the task, so its value can’t be set. 

This property is active and its value must be set.
This property is "Read only", and its value can’t be changed. Unlike system property, value of 
read only property affects task results.
A  property  can  become  “read  only”  either  by  user’s  choice  (selection  of  "Property 
Permanently ReadOnly" command in contextual menu) or by such combination of values of 
other properties that allow only single value of this property. 
This property is disabled. If parent property is inactive or read only,  nested properties are 
disabled.  

Disabled and other inactive properties are shown in grey. 
A program can have optional parameters, so some properties may be switched between active 

and inactive states by checking/unchecking the box: / . Other properties are permanently 
active. Active properties are used by a task, inactive are not. 
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Examples of disabled properties are below.

«Perform gapped alignment»  property is  optional  and set  active  (box is  checked),  its  nested 
properties  are  «Open  Gap  Cost»  and  «Extend  Gap  Cost».  If  «Perform  gapped  alignment» 
property is set inactive (box is unchecked), nested properties «Open Gap Cost» and «Extend Gap 
Cost» are disabled.

If a property is inactive, all nested properties are inactive as well, so Property Editor disables 
editing their values.

A property is also disabled if its parent property is read only, for example:

If  «Multiply variants……» property is set to read only,  all  nested properties except  selected 
become disabled, and selected properties become read only.

 Contextual menu of Property Editor

Contextual menu of Property Editor contains the following commands: 
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• Collapse All - collapse all nodes. 
• Expand All - expand all nodes. 
• Top position - go to the top of a list. 

• Copy Value - copy property value to clipboard. 
• Paste Value - paste property value from clipboard. 
• Copy Property String - copy property name and value to clipboard. 
• Open folder - open folder where selected file is located.
• Open with text editor - оpen file using text editor. 
• Open with viewer - open file using special graphical viewer (must be installed). 

• Property - Rename - rename a property. Displays "Rename Property" dialog. 

• Property - Move Up - moves property up. Property can also be moved within nested 
group of parent property. 

• Property - Move Down - moves property down. 
• Property - Permanently Active – makes an optional property permanently active, i.e. 

mandatory. This action can’t be undone in current View.   
• Property - Permanently Hide - Hides property, locking its value and activity status at 

the same time. This action can’t be undone in current View.   
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• Property - Permanently ReadOnly – makes property read only. All active nested 
properties also become read only, while inactive nested properties become disabled. This 
action can’t be undone in current View.   

• List Item - Rename - Some properties have only a fixed set of acceptable values. For 
instance, genefinding parameters for FGENESH can only be human, mouse, Drosophila 
etc. This action renames one of such values chosen from a list, for instance user can 
change Drosophila to fruit fly. Displays "Rename Item" dialog.  

• List Item - Permanently Active - make a list item permanently active, i.e. locks 
property value at this list item. This action can’t be undone in current View.   

• List Item - Permanently Hide - hides a list item permanently, i.e. deletes it from a list of 
acceptable values. This action can’t be undone in current View.   

• List Item - Permanently ReadOnly - set nested properties of this list item into read only 
mode, i.e. they become unavailable for editing. This action can’t be undone in current 
View.   

• SubNodes - Permanently Hide - hide children nodes. This command is available for 
radiogroups only. This action can’t be undone in current View.   

Warning! All commands with «Permanently …» in their names can’t be undone in the current 
View. Therefore, before taking such actions, create a copy of current View so that you can 
restore original View. Otherwise, in order to undo such actions, you’ll have to create a new View 
from scratch.

 Values of properties

Depending on property type, values can be: 

• selected from a list 
• typed in manually 
• files selected using standard Select File dialog, which appears when the corresponding 

button in property value column is pressed. Full path is required for input files, for output 
files - filename only. Path to a file can be typed in or selected in Select File dialog. You 
can also drag and drop files or paste them from a clipboard. In certain cases, files can be 
selected from a drop down menu. 

For properties that define input data source, there are three possible value variants: File, 
Files list and Pipe: 

• File - data are located in a file with user-specified path. Icon  indicates that specified 
file exists, icon  - that path or filename are incorrect, i.e. file cannot be located. 

• Files list – a list consisting of one or more files created in File List dialog (evoked by 

pressing  button) is used as an input. In such case MolQuest runs several passes, one 
file from a list at a time, in the same order they appear in a dialog window, until all files 
are processed. Results of each pass are shown in a list in Results tab. Icon  indicates 
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that file list is empty, while  means that it is not.  

In File List dialog (see picture below), pressing  button opens standard Open File window, 
which is used to add files to a list.

Order of files in a list can be changed by using    and   buttons. 

To remove an individual file from a list, press   button, and to remove all files,  button. 

• Pipe – input data are taken directly from output of another task in the same project. 
Correst  link to pipe data source is indicated by icon  ,while undefined or wrong link 

– by icon . Similarly, icon means that destination for output data is correct, and 

that link is not defined or incorrect. 

To choose the link for input data, use   button, which displays "Select Task Output" dialog 
with list of outputs of task within current project. 
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Some properties are mutually exclusive, i.e. if value of Property 1 is set, value of Property 2 
cannot be set. Such properties are grouped into a radio node. In such cases, a separator “::” is 
placed after a name of a node (parent property), separating it from a name of selected nested 
property.  User can change this default style with alternative ones in Rename Property dialog 
below. 

For example, label "Multiply variants::Non-Overlapped variants::Number" means that parent 
property  "Multiply  variants"  has   nested  property  "Non-Overlapped  variants"  selected  as  its 
value, and this property "Non-Overlapped" has its own nested property, "Number" as its value:

Property Rename command in the contextual menu opens Rename Property dialog. If  "Absolute 
Name" box is checked, name of selected nested property won’t be added to node name after a 
separator.

 Description page 

Description page contains brief descriptions of some selected properties or their values. 
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 Constrains page

Constrains page contains requirements to values of some properties (value type, minimum and 
maximum value etc.) 

Project tab
Project tab contains a list of tasks in a current project:

The table has the following columns:

N - the order number of each task.
E – displays the current Ready State.
State - displays the current Execution State of a task.
In - displays source of Input Data.
Out - displays destination of Output Data.
ID - displays unique ID of a task. in a project.
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Task Name - displays the name of a task. 
Pass – displays number of completed passes / total number of passes. 
Results column contains shortcuts to task results (output):

 - Results Folder - opens a folder with output files and log files 
- Results File - opens “text/plain” file containing task output, if not empty. If this icon 

is shaded: , MolQuest can’t find text viewer for this “text/plain” file.
 - Results Files – opens nonempty “text/plain” files containing task output. This icon 

appears instead of the Results File ( ) icon if more than output file was generated by a 

task. Shaded icon  indicates that either multiple passes resulted in creation of several 
sets of output files, which can be viewed in Results tab, or MolQuest can’t find a viewer 
for these files

 - opens output in a graphical viewer. MolQuest has multiple graphical viewers for 
many output file formats.

 - more than one output file is available for viewing with graphical viewers.
 - multiple passes resulted in sets of output files. 

Processing – time it took to process task 
Start Time – time when task started. 

 Task Status 

Ready State

This is a status of task’s readiness for execution: 

Not Ready. Some required properties are not defined and/or some of their values 
are set incorrectly. 

  Ready. All required properties were defined. 

 Enabled. This task will be run during the execution of a project. 

Completed. The task is completed.

Execution State

This is current execution status of a task. Move the mouse cursor over a status icon to display 
details. 

The task has not been started.
In Progress. The task is being run now. 

 Completed. The task was completed without errors or warnings. 

 Completed  with  Warnings –  Some  warnings  or  errors  occurred  during  task 
execution, and at least one pass has finished without errors. Put a mouse over the 
icon to see a diagnostic message.  Сlick the shortcut in Results column to open a 
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log file. 

 

Completed With Error – There are no passes that finished without errors. Every 
pass of the task were been executed with errors. A task has no meaningful results 
to use or to send to a pipeline.  Put a mouse over the icon to see a diagnostic 
message. Сlick the shortcut in Results column to open a log file. See also Results 
Tab for more information

 
Aborted. User aborted a task on the first pass. No results to use or to send to a 
pipeline. 

 Input Data 

If a task is part of a pipeline, state of input data is displayed here.   icon means that a task 
uses an output of one pipe as input data,  means that it uses more than one input pipe. Shaded 
icons ( ) mean that all input data are ready but are not currently in use by other task, blue 
symbols ( ) mean that input data are currently being used by running task, red symbols (

) mean that some data are not ready. 

 Output Data 

Tis column has the same meaning as the «Input Data» column, but for output data of a task. 

Results Tab
This tab shows a list of all passes for selected task, with their states. 

For many programs, a list of files can the set as an input, in which case each file from a list will 
be processed by a separate pass of a program. If a task has more than one property set as a list of 
files, all combinations of files will be processed. For instance, if Property 1 is specified as a a list 
containing three files, and Property 2 as a list of four files, there will be 4 x 3 = 12 passes, each 
one combination of input files. Total number of passes for one task cannot exceed 100,000. 

The column in Results tab have the following meaning: 

• Pass – an order number of current pass; 
• State - pass status: 

- in process; 
- completed without errors or warnings; 
- completed with warnings; 
- completed with errors; 
- aborted. 
• View – view results. Icons have the same meaning as those in Results column of 

Project Tab, but for current pass only.
• Processing - pass processing time; 
• Start time - pass start time. 
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For a pass selected in Results tab, the following information is displayed: 

In the Input Files page, input files that were used by current pass: 

Type - source of input: 
- file, 

• - pipeline. 
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View – preview input files. Icons are the same as those in Results column of Project Tab, 
but for current pass only.

File - path of an input file or pipe identifier.

In the Output Files page, a list of output files with their status and shortcuts to preview: 

Type  - possible output variants: 

• - Normal results file; 
• - Warnings log file; 
• - Errors log file.

View – preview results. Icons are the same as those in Results column of Project Tab, but 
for current pass only.

File - name of output file. 

Pipeline tab
The Pipeline tab is intended for viewing and editing of MolQuest projects as block diagrams. It 
provides convenient way for creating pipelines, where output data generated by one task is used 
as input data for another task. 

In  Pipeline  tab,  every  task  or  converter  in  a  project  is  shown  as  a  box,  with  task  name 
underneath, input slots, representing input data, in left half of a box, and output slots in its right 
half. Moving mouse pointer over a slot displays a name of property corresponding to that slot. 
Boxes  can  be moved  and resized,  and slots  can  be  moved  and rearranged  within  their  box 
halves. Selecting a task in Pipeline tab also selects it in Project tab, and vice versa. In Property 
tab you can view and edit properties of a selected task. 

If output data of one task is used as input for another task, corresponding output and input slots 
are linked by a line. An output slot can have several outgoing links; an input slot can have only 
one incoming link. To link tasks, click on slot, move pointer to a slot of another task, and click 
there. Clicking on a first of two slots to be linked enters mouse pointer into linking mode. In this 
mode, a pointer turns yellow when between slots, and is followed by a yellow line, it becomes 
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green on slots that  are permitted to be linked,  and red on slots that  can’t  be linked.  To exit 
linking mode, click anywhere outside slots.

You cannot link tasks if: 

• You are trying to link input to input or output to output. 
• Both ends of a link point to the same task, or links form endless loop. 
• An input slot belongs to a task that is currently running or has been completed. 
• An input slot is already connected. 

Completed  link assumes  various  styles  and colors  depending on compatibility  of formats  of 
linked output  and input.  Light  gray solid  line means that  input  and output  data  formats  are 
compatible without using a converter. Light gray dotted line means that input and output formats 
are compatible after using a converter that was automatically selected by MolQuest (so-called 
implicit converter) and included in a project, implicit converters are not shown as separate tasks. 
If MolQuest cannot automatically select a converter, the line is shown as solid dark gray. If user 
adds a converter to a project (explicit converter), it must be inserted between two corresponding 
tasks, and is shown in Pipeline tab as a task. Lines to/from explicit converter are shown in blue. 
If one or both linked slots are inactive, the link is shown as a dashed line. Pipelines containing 
formats judged by MolQuest as incompatible, or containing explicit converters, can be run, but 
user has to be sure that he can get meaningful results. 

Formats for input and output data are compatible. 

Formats are incompatible, but converter is found and added automatically. 
Formats for input and output data do not match and MolQuest cannot automatically 
find an appropriate converter.
Formats  do  not  match  selected  converter  (will  be  shown  for  explicit  converters 
unknown to MolQuest). 

Output is disabled.

Input is disabled.
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The format of input file is a subset of a format of output file. For example: Input file 
format is "Fasta", output file format is "Multifasta". 

To delete a link, click on its input. You can’t delete input links of running or completed tasks. To 
delete tasks or converters, use Project tab. To edit task properties, use the Property tab. To add 
new task or converter, use Toolbox tab. 

Properties  of  a  completed  task  cannot  be  edited.  If  you  want  to  alter  some  properties  and 
preserve task results, use Task->Copy Task command in the main menu and edit properties of a 
task copy. 

Repository tab
User may want to create libraries of tasks and projects, to be used as templates and building 
blocks blocks for creating new tasks/projects. MolQuest has a repository which can be used for 
such purpose: Projects (Projects page) and tasks (Tasks page) with user-defined properties can be 
saved in Repository tab.

Task page 
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This page contains a list of user-defined groups, each of which can include a number of 
tasks. Groups can be created, deleted, renamed, or their content can be changed using 
contextual menu commands: 

• Auto Collapse Groups – if checked, collapses all groups except selected. 
• Collapse All - collapses all program groups. 
• Expand All - expands all program groups. 
• Rename Group – displays "Rename Group" dialog. 

• Delete Group - remove selected group from a list. Warning! All tasks in that group are 
deleted as well. 

• Rename Task - displays "Rename Item" dialog, in which selected task can be renamed. 

• Delete Task - removes selected task from a group. 
• Add New Group - displays "Add New Group" dialog. 

• Add Current Task - Displays "Add New Task" dialog, where selected task from a current 
project can be added to a group. Clear Input: if checked, all input values are erased. 

Projects page

Projects page contains a list projects grouped into user-defined groups. As on tasks 
page, groups can be created, deleted, renamed, or their content can be changed using 
contextual menu commands: 
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o Auto Collapse All - if checked, collapses all groups except selected. 
o Collapse All - collapses all program groups. 
o Expand All - expands all program groups. If "Auto Collapse" mode is active, 

only group is expanded 
o Rename Group - displays "Rename Group" dialog, similar to that of Tasks page. 
o Delete Group - Deletes selected group and all projects it contains. 
o Rename Project - displays "Rename Item" dialog fro renaming selected project. 

o Delete Project - removes selected project from a group. 
o Add New Group - displays "Add New Group" dialog. 
o Add Current Project - Displays "Add New Project" dialog for adding current 

project to a selected group. Clear Input: If checked, all input data are deleted, but 
pipeline links remain in place. 
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• To load a project from repository, click on it. "Save Project As" dialog will be displayed, 
where you can type project name and title and choose location for it to be saved in. 

Manager tab

Manager tab contains a list of opened projects. Projects can be dragged by a mouse up and down 
a  list.  Click  on  a  project  name  to  switch  to  that  project.  Comments page contains  some 
comments on selected project. 
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Contextual menu commands of Manager tab: 

• Rename Project - displays "Rename Project" dialog. 

• New Project - Displays "Create new Project" dialog, where you can enter a folder name 
for a new project, as well as choose its location. If project folder with the same name 
already  exists  in  chosen  location,  or  contains  invalid  symbol  (those  not  allowed  in 
Windows  filenames),  the  "OK"  button  is  inactivated.  Entered  folder  name  is 
automatically assigned as a title of the project, which is shown on top of Project Panel. 
You can change a title, it doesn’t have to match to the folder name or be unique. 

• Open Project - displays the "Open Project" dialog for opening and existing project. After 
opening, a project assumes a status of current project. 
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• Reopen Project - Reopens current project without saving any changes. 
• Save All - Saves all projects at their current stage of progress. 
• Save Project - Saves selected project at its current stage of progress. 
• Save project as - displays the "Save Project As" dialog, used for copying all tasks of 

selected project, as well as their properties, if defined, into a new project. Tasks results 
are not copied, completed tasks switch their states to Ready,  states of other tasks are 
unaffected.  Fields in "Save Project As" dialog are the same as those in “Create New 
Project”:

• Close Project - The project is saved at its current stage and closed. 
• Close All Projects – All opened projects are saved and closed. 
• Load Projects  List  –  Load  projects  from previously  saved  projects  list  using  “Lad 

Projects List” dialog. If Manager tab currently contains any projects, loaded projects are 
appended to it. If a project was deleted, it is automatically removed from all lists. 
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• Save Projects List – Save the list of currently opened projects, i.e.  those displayed in 
Manager Tab.

• Run Project - runs a project. Only enabled tasks will run. 
• Stop Project - stops execution of a project upon completion of currently running task. 
• Abort Project – immediately aborts a project, without waiting for running task or its 

pass to complete. 
• Enable All Ready Tasks - enables all Ready tasks in a project.
• Disable All Enabled Tasks – Changes status of all Enabled tasks to Ready. 
• Delete All Results - deletes results of all completed tasks. 
• Clear Project - Deletes all tasks from a project. 
• Delete Project - deletes current project. 

View/Console tab

View/Console displays output of a pass selected in Results tab (by default – first pass), if such 
pass resulted in an output. Selecting and copying text in this window is limited to visible lines. 
Vertical scrolling removes text selection.
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Task tab

The Task tab contains certain information about selected task and consists of two pages: 

o Comments - User comments on a task
o Quick help - Short program help.

To Do tab

To Do tab represents a list of items and serves as a scratchpad or to do list. An item can be added 
by double-clicking on empty line or from contextual menu. It can be changed by double-clicking 
on an item or from contextual menu. 

C column displays status of item completion, 

! column indicates item priority; 

Category - item category; 

Caption - item name; 

Date Add - date and time of item creation; 

Date End - date and time of completion. 
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Contextual menu has the following commands: 

Add - displays "Add To-Do Item" dialog with fields corresponding to columns 
mentioned earlier on this page, plus  Task commentary field which provides 
commentary on an item. 

Add Copy - adds a copy of existing item to a list. Displays "Add To-Do Item" dialog which 
already has fields pre-filled with properties of copied item. 
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Edit - edits an item; 

Delete - deletes an item; 

Show Completed Items - displays/hides completed items; 

Show Full Time - if checked, displays time and date, otherwise date only. 

Save As XML - saves a list in a file in Unicode XML format. 

Sort - sorts items by one of the following criteria: 

  Completed 
  Priority
  Category
  Caption
  Date Add
  Date End

Items can also be sort by clicking on corresponding column header. 

Status Bar

Status Bar displays the following information. 

Resource usage: 

• CPU Usage: - CPU percentage usage. 
• Memory Usage: - percentage of memory used. 
• Free: - amount of free available memory. 

Project status: 

• Project not specified - no project is opened. 
•  N - Projects in progress - the number of projects running. 

Profile Manager
Profiles are designed for fast switching between different MolQuest settings. Profiles can include 
common application parameters (see Options dialog) window sizes, tabs location, headers sizes 
etc.

"Profile Manager" dialog allows changing profiles or creating new ones. Profile named 
“Current” contains MolQuest settings currently in use. 
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Pressing Copy button creates a copy of selected profile, Rename button renames a profile, and 
Delete button deletes it.  

To create a new profile, select an existing one, create a copy and then edit it. Profile containing 
current MolQuest window and options setting always exists with name “Curent”. 

Enter name of new profile and press OK, a new profile will be created. 

Main Window/Panels Settings. – determines window sizes, tabs location, headers sizes etc.

If checked, a profile sets window/panel parameters. If unchecked, a profile doesn’t set these 
parameters. If current sizes of windows and panes differ from those of current profile, Setup 
button is enabled. Pressing it saves current settings in current profile, and Setup button becomes 
disabled again.

Options Settings – determines common application parameters. 

If checked, a profiles common application parameters, if unchecked, a profile doesn’t set them. 
"Setup" button displays Options dialog, where common application parameters can be changed. 
Checkboxes in Options dialog have three possible states: usual on  and off  and also 
unchanged , meaning that current setting doesn’t change by changing profiles. 

Panels dialog
There are four zones (panels) in MolQuest main window, each containing various tabs: Left, 
Right, Center and Bottom:
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Panel boundaries can be moved by a mouse.

Panels dialog is a convenient tool for rearranging tabs in the main window. Drag a tab name to a 
zone where you want it to be located. If you want to hide a tab, drag its name to an "OFF" group. 

Options dialog
Options dialog is displayed by choosing Tools>Options from Main Menu and is used to view or 
change various MolQuest settings. It has six tabs:

• Prompts   
• System tray   
• Misc   
• Projects   
• Memory       
• View/  Console  
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Prompts tab
Sets operations for which confirmation prompts will be displayed: 

• Before deleting a task 
• Before deleting task results 
• Before aborting a task 
• Before deleting a repository task 
• Before deleting a repository project 
• Before deleting a project 
• Before deleting project results 
• Before aborting a project 
• Before clearing a project
• Before deleting to-do item- displays a confirmation prompt before deleting an item from 

To-Do list.

System Tray tab
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Enable  System tray – MolQuest icon is displayed in the system tray.
Minimize to system tray –MolQuest main window is minimized to the system tray. Clicking  it 
restores main window.
Show project complete hint - Once the project is finished, a message "Project complete 
"Project name"" is displayed in one of the following cases: 

• Never 
• Application minimized 
• Application not active 
• Always 

Auto hide interval (sec) - Project completion message disappears after specified time. 

Misc tab

• Highlight CPU usage bar - check to display percentage of CPU usage in graphical form 
and as a number. If unchecked, only a percentage number is displayed. 

• Show Grid in pipeline editor - check to show gridlines in pipeline editor. 
• Show splash information window - check to show splash window on a single project 

open/close. 

Projects tab

Contains Project settings. 
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Open last projects at start-up – check to make MolQuest open at startup all projects that were 
open at the end of last session. 
Update project Input/Output data – Makes MolQuest check that all necessary input/output 
files are available (exist  and are readable).  If any of them are unavailable,  it  is displayed in 
Results Tab, Output Files Page and/or Input Files Page. 

• On load project – files are checked when a project is loaded. 
• On change project – when projects are switched in Manager Tab.
• On application activate – every time MolQuest becomes current application.

 Memory tab

Settings of monitoring system memory  

Memory used exceeds – if checked, displays the warning on a status bar (Status Bar), if percent 
of memory used exceeds preset percentage threshold. 

             

Free memory less than - if checked, displays the warning on a status bar (Status Bar), if free 
memory falls below preset threshold in MB. 
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View/Console tab

Contains View/Console tab settings. 

• Activate View/Console - activate/deactivate View/Console tab.
• Show results - show result files of a chosen task on    View/Console tab  .
• Show warnings - show warning files of a chosen task on    View/Console tab  .
• Show errors – show error of a chosen task on    View/Console tab  .
• Console Mode – If checked, all output data are displayed in real time in a console while 

a task is running. 
• Column Selection Mode – switch between column and line selection modes. 
• Wrap by View Width – wrap lines in View/Console tab window.
• Show Left Ruler – Display left-side ruler with line wrap symbols, if exist. 
• Show Top Ruler – Display top-side ruler on top of window. 
• Absolute Wrap – Forces wrapping lines larger than 4096 characters. Applicable only to 

files <1 MB in size, as larger files are always force wrapped. 
• Tab Width – sets tab width
• Font – pressing Setup button opens a font selection dialog. Selected font must be of fixed 

width, though a dialog shows all fonts. 
Reopen Mode – applicable only if console mode (see above) is off. Sets mode of 
refreshing displayed output file: No - not refershed;  Auto – automatically refreshed; 
Message – when file is changed, asks user whether to refresh.

Property Editor Options dialog
This dialog controls some visual and dynamic parameters of Property Editor settings, which de 
don’t describe here in details. Pressing Default button resets all options to default. 
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Templates
User can integrate console applications into MolQuest GUI shell on his own. To do this, add 
"Standard  Template"  task  from  Templates  group  of  Programs  list  of  Toolbox  tab.  In  this 
template, name and path to an executable file, as well as its running options (input and output 
files, command line options and other necessary information) have to be specified. 

In drop down list at the very top of  Properties Tab, maximum allowable number of input files 
(NN Input),  output  files  (NN Outputs)  and  command  line  options  (NN Options)  has  to  be 
specified.. For example, "01 Input; 01 Output; 05 Option" means that application can have no 
more than one input file,  one output file and five command line options. Once a program is 
added, all unused properties can be hidden. 

Template properties include the following sections: 

• System - contains the information on template and task names, and task ID; 
• exe - selects executable file of console application; 
• Input – specifies types of input data; 
• Output - specifies types of output data; 
• Option – sets up command line options. 

System section 

• Task Name field contains the current task name. It can be changed. 
• ID - task identifier. 
• Program - template name. 

exe section 

• Exe File - path to application executable file. 
• Quote Type - rules for command line quoting (depends on compiler). It is necessary to 

specify if properties can contain nonstandard or punctuation characters. 
• Run exe destination - work directory of application executable file. There are two 

variants: Auto - MolQuest chooses work directory; or Exe path – work directory is set to 
location of exe file. 
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Debug Log File - name for MolQuest debug file, which contains the executed command 
line and other information about the application. Data in that file can be useful for 
troubleshooting and testing program integration.

Common rules for editing the application options: 

As for MolQuest’s own tasks, "Input files" can be single or multiple files and can be specified by 
user or taken from a pipeline, and output files can be sent to another task via pipeline. 

To activate a property, the appropriate box should be checked ( ). 

To prevent property from being displayed (e.g. a property that doesn’t change its value in all 
conceivable  task  variants),  right-click  on  it  and  choose  "SubNodes  -  Permanently  Hide" 
command from contextual menu. 
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The item becomes invisible, but its value is sent to a command line if that property is active. 
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Property name can be changed using "Property Rename" command from contextual menu. 

Input section 

To define program input, two subsections: XX.Option and XX.Input shall be filled.

01.Option - describes the way to specify input file name in command line: 

• Order  - position number of this option in command line. By default, 0.  
• Key - prefix for current option. 
• Space - "no" means no space between prefix and value, otherwise - "yes".

 
01.Input. Choose appropriate type of input data from drop-down list: 

• File - data will be taken from a file with user-specified path. Icon  means that file 
exists,  - path to file is wrong or file does not exist. 

• Files list – a list consisting of one or more files created in File List dialog (evoked by 
pressing button) is used as an input. In such case MolQuest runs several passes, one 
file from a list at a time, in the same order they appear in a dialog window, until all files 
are processed. Results of each pass are shown in a list in Results Tab. Icon indicates 
that file list is empty, while means that it is not.
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• Button  adds files to a list. In a dialog, user can select one or more files and press 

"Open" button, buttons  and  move files up and down in a list, button  removes 
selected file from a list, and button  clears list, removing all files.

• Pipe - data will be taken directly from another task in a project. Icon  means that a 

link to input data source is correct, that a link is not defined or wrong,  means 

that output data destination is correct, and that a link is not defined or wrong. 

Output section 

To define an output file, two subsections: XX.Option and XX.Output should be filled.

01.Option -  describes  the  way  to  specify  the  output  file  name  in  a  command  line:  

• Order - position number of this option in command line. By default, 0.
• Key - prefix for current option. 
• Space - "no" means no space between prefix and value, otherwise - "yes".
• Type-  from a drop down menu,  select  how an output  is  treated:  as data,  as warning 

messages, or as error messages. 

01.Output. Choose output type from drop down menu: 

• File - output file with specified name will be generated in the task-specific folder. 

• Pipe - output file will be sent to an appropriate pipeline. Icon  means that output 

data destination is correct, that link is not defined or wrong. 

STDOUT.Options 
• Type- select in the drop down menu how the application standard output is treated: as 

data, as warning messages or as error messages. 

STDOUT.Output. Choose type of output data from drop down list: 
• File - output file with specified name will be generated in the task-specific folder. 
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• Pipe - output file will be sent to an appropriate pipeline. Icon   means that output 

data destination is correct, that link is not defined or wrong.
If STDOUT subsections are not set, but a program outputs data to standard output, it would 
generate a warning. 

STDERR.Options 
Type- select in the drop down menu how the application standard output is treated: as 
data, as warning messages or as error messages.

STDERR.Output. Choose type of output data from drop down list: 
• File - output file with specified name will be generated in the task-specific folder. 

• Pipe - output file will be sent to an appropriate pipeline. Icon   means that output 

data destination is correct, that link is not defined or wrong.
If  STDERR subsections are not set, but a program outputs data there, it would generate a 
warning.

Options section 

To define an option, two subsections: XX.Option and XX.Value should be filled.  

01.Option - describes the way to specify an option in command line: 
• Order - position number of this option in command line. Default value is 0. 
• Key - prefix for current option. 
• Space - "no" means no space between prefix and value, otherwise - "yes".

01.Value. choose an appropriate type of option data: 
• String 
• Integer 
• Real 
• Char 

Once  selection  is  done,  all  unused  subnodes  can  be  hidden.  To  do  so,  use  "SubNodes 
Permanently Hide" command from contextual menu. 

Once all properties have been specified, the task can be added to repository (Repository Tab) for 
further use in various projects. 

E-mail for product information: softberry@softberry.com 
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