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 Introduction 

MOLQUEST is the most comprehensive, easy-to-use desktop application sequence 

analysis and molecular biology data management available in the market today. The 

package includes versatile family of genefinders, FGENESH/H+, with parameters for 

wide variety of genomes, as well as pipelines for fully automatic annotation of 

eukaryotic (FGENESH++) and bacterial (FGENESB) genomes, which proved to be 

the most accurate genefinding tools overall (see here) The package has a user-friendly 

interface for sequence editing, primer design, internet database searches, gene 

prediction, promoter identification, regulatory elements mapping, patterns discovery 

protein analysis, multiple sequence alignment, phylogenetic tree reconstruction, and a 

wide variety of other functions. 

E-mail for product information: softberry@softberry.com 

E-mail for MolQuest Technical Support: support@molquest.com 

 Fundamental Definitions 

Program  

MolQuest integrates various programs for molecular biology data processing. 

Programs are distributed by their developers in packages. Packages are installed by 

the main menu command Tools -> Install Package. All available programs are 

displayed in Programs Sheet of the Toolbox tab. 

Task  

In MolQuest, a task is a command to run a program using certain values of its 

parameters (properties). Same program with two different sets of values of its 

parameters is considered to represent two different tasks. Current status of a task 

(being processed, finished, ready) is displayed in Project tab .Tasks can be joined in 

pipelines with pipes connecting their slots. 

Project 

Project is the key element and executable unit of MolQuest workflow, consisting of 

an ordered set of tasks, defined by user. For each new project, MolQuest creates a 

separate folder. That folder contains subfolders corresponding to each of a project's 

task, where those tasks' outputs are written and can be accessed by user. A list of a 

project's tasks is shown in Project tab and Pipeline tab . While executing a project, 

only tasks with status Enabled are executed (see Task Status). 

View  

Quite often, users run the same program with varied values of program's parameters 

(properties). Each set Program + Properties can be specified as a separate task: for 

http://www.softberry.com/
mailto:support@molquest.com
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instance, program P with several different sets of parameters can be defined as several 

separate tasks, T1, T2 etc. In many cases, however, an alternative approach, which 

uses MolQuest's concept called View, is more convenient. View is a set of parameters 

values within a task, so that instead of separate tasks as above we get a set of separate 

views, V1, V2 etc. Each task has at least one view, Current View, which is used when 

task is executed. Each of existing views within a task can be set as Current View, 

which is done when user wants to run a task with a different set of values of program's 

parameters. 

User can not only set parameters to different values, but also hide non-essential 

parameters from being shown Properties tab. For instance, user can take view V1 and 

hide all non-essential parameters, creating view V2 - identical in all respects except 

visual representation of parameter values. This is useful in case of multi-parameter 

tasks, when only few parameters are varied, while the majority remain the same and 

are hidden from view in order not to distract user. 

Converter  

In most cases of pipeline-like queues of tasks, an output of one task, supposed to be 

used as an input of another task, has format that is incompatible with "downstream" 

task. To convert an output to format suitable for another program, special auxilliary 

programs, called converters, are used. In many cases, MolQuest can automatically add 

an appropriate converter to a pipeline. As most programs, converters are distributed in 

packages. The Converters Sheet in the Toolbox tab shows all available converters. 

 
 

Output from one task is often used as an input for another task. In the previous version 

of MolQuest, we used pipes to transfer data from one task to another: every task 

output could be connected with one or several pipes, and every input could be 

connected with a single pipe. So tasks could be joined in pipelines. Now for more 

flexible data processing we introduce next generation of task connection system, 

which allows use several pipes in an input slot. New pipeline are not just a sequential 

order of tasks, but allows loops, conditions and processing complex sets of data in 

desirable order.  

Now we have new entity between pipes and task input/output, which is called slot. 

Slot controls dataflow of pipes. An input slot gets data for a task input from pipes and 

files, an output slot sends corresponded task output to pipes and files. Data 

arrangement in an input slot depends on slot settings, received internal signals and 

pipes contents. 

Data item  

Data item is a portion of data which can be used by a task input or generated by a task 

output. If our task were a standalone console application, data item usually would 

have corresponded to a file, either input or output. 
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Slot  

Slot is a data item manager. Slot can buffer data items, send and receive signals, 

perform some action on particular events. For a given task, an input slot gets data 

items for a task input from pipes and files and arrange them in desirable way, an 

output slot sends corresponded task output data items to pipes and files. Slots are 

automatically created for all task inputs and outputs. 

Pipe  

Pipe is a channel between an input and an output slot. A pipe transfers data items and 

flags from its output slot to its input slot. 

Pipeline  

Pipeline is a set of tasks, connected by pipes. The Pipeline tab displays all links 

between tasks in a pipeline. Predefined pipelines from packages are shown in 

Pipelines Sheet of Toolbox Tab.   

Flag  

Flag is a special object which can be send by a pipe from its output slot and requires 

some actions from its input slot when received. Now there are two types of flags: 

Complete Queue and Complete Pipe. 

Signal Signal (Internal signal) is a message which can be sent by a slot or a task to all 

slots of the task. 

Static data of a slot are data items from explicitly set sources, for example, from a 

file or a list of files. 

Dynamic data of a slot are data items from pipes connected to the slot. 

Queue 

Queue is a sequence of data items and flags delimited by Complete Queue flags. 

Queue can contain both static and dynamic data, static data always precede. If a queue 

contains only static data, a Complete Queue flag is not necessary. 

 Getting Started 

As we now know, in order to execute even a single task, user has to create and 

run a project. Here we discuss how to work with projects. 

The user also may create pipelines. 
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 Create/open a project. 

To open an existent project, choose File->Open Project in the main menu. Then 

choose the project's folder. 

To create a new project, use File->New Project in the main menu. In the "Create 

new Project" dialog, enter folder name for a new project. It will also be assigned as a 

name of a project itself. If you want to change the location of the project folder, press 

Browse button. If the project folder already exists in the current location or contains 

invalid symbols, the "OK" button in the "Create new Project" dialog will be inactive. 

The project name is shown on top of the  Project tab . You can change the name, it 

does not have to match the folder name or be unique. Press the "OK" button to 

confirm. A new project with the specified name has now been created. 

 Add tasks to the project. 

Choose a program group in Toolbox Tab and double click to a program to append it to 

a list in  Project tab . Generally, the task is not yet ready and cannot be enabled unless 

its mandatory parameters (also called properties) are assigned values - for instance, 

FGENESH cannot run unless genefinding matrix (human, monocot plants etc.) is 

specified. Project tasks are also displayed in Pipeline tab. 

 Define task properties 

TThe properties (parameter values) of a task can be edited in Property Editor 

of Properties tab. . Before a task can be executed, you must set values to all necessary 

parameters. If a mandatory parameter is not set or its value is wrong, MolQuest 

highlights it with red color and "!" mark, like this: 

 

 Enable a task 

Since only enabled tasks are executed during the project, a task scheduled for 

execution should be enabled first. To enable a task, do one of the following: 

 Use the Task->Enable Task command on the Main Menu 

 In the list of project tasks, tick the check box  in the "Status" field. 

 Press the  button. This enables all tasks within a project that are in "Ready" 

status. 

Only tasks that are in "Ready" status can be enabled (see Task Status). 

 Run a project 

When a project is run, its tasks are executed one by one in the same order as they 

appear in the list of project tasks, from top to bottom (Project tab ). A user can, at any 

time, change an order in which tasks are executed. To change an order, use Task-

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.7-TaskProperties.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.7-TaskProperties.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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>Move Up and Task->Move Down commands of the Main menu or  and

 buttons. 

To run a project, do one of the following: 

 use the Run->Run Project command on the Main Menu 

 Press the  button on the Toolbar. 

If you want to execute only one task of a project, select the task at the Project tab  or 

the Pipeline tab and click . If you run a single task rather than a project, that task 

can have not only status "Enabled" , but also "Ready". 

When a task is being run, its status is "In Progress" ( ) status (Task Status). 

Completed tasks have status "Completed" ( ) status (Task Status). 

If an error occurred during the execution of a task, the task gets either "Completed 

with Warnings!" ( ( or "Completed with ERROR!" ( ( status (Task Status). 

 Interrupting execution of a project or a task 

To interrupt execution of a project, do one of the following: 

 Press the  button or use Run->Stop Project command in the Main menu. 

This stops the execution of a project immediately after completion of any task 

pass that is currently running. 

 Press the  button or use Run->Abort Project command in the Main menu. 

This aborts a task currently running and stops the execution of a project 

immediately. 

To interrupt the execution of a task, do one of the following: 

 Press the ( ) or use Task->Stop Task command in the Main menu. Stops the 

execution of a task immediately after completion of a pass that is in progress. 

 Press the  button or use the Task->Abort Task command on the Main 

menu. Aborts a task immediately. 

If you interrupt a task, a project continues running, the next task in a queue being 

executed, unless you run a single task by pressing a  button (see above). 

 Viewing results 

Executed task assumes one of three states: 

 "Completed" - Normal completion, output was created 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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 "Completed with Warnings" - Output was created, but may be wrong: user 

should check warnings. 

 "Completed with Errors" - Output may be missing. Even if it exists, it is 

wrong. 

An output of a task can be viewed in  Project tab  (column "Results"), Results 

Tab or View/Console Tab. 

 Create pipelines 

A project may consist of a complex sequence of tasks, where an output of one task is 

used as an input for another. Such kind of project is called a pipeline. 

There are two ways of making an output of one task an input of another task: You can 

use either Property Editor or Pipeline tab. 

In Property Editor > In Slots page, use "Pipe" parameter for required input source. 

The  button appears which, when pressed, displays "Select Task Output" dialog 

listing outputs of all project's tasks that can potentially be used as inputs. 

 

Alternatively, you can use Pipeline tab , which displays MolQuest projects as block 

diagrams in user-editable form. 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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Here, to create a pipeline, connect output and input of corresponding tasks with a 

mouse: click on an output of a task, and a cursor takes this form:  , now move a 

cursor to an input area of a "downstream" task. Yellow line will follow a cursor there. 

If two tasks cannot be linked in a pipeline, a cursor transforms into this icon: . If, 

however, link is possible, it will look like this:  . Click on an input area, and two 

tasks are linked into pipeline relationship. Similarly, you can start with an input field 

of a downstream task and move to output field of an upstream task. In such case, 

cursor will assume this look:  . 

If output and input formats of tasks are compatible, a pipeline link between them 

looks as a solid gray line: . If formats are incompatible, but a correspondent 

converter is registered with MolQuest, a link looks like a dotted gray line: . 

Finally, if formats are incompatible and there is no converter available, it looks as a 

black line: . 
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 Application window 

 

 

1. Toolbox Tab. 2. Repository tab. 3. Manager Tab. 4. Status bar. 5. Main menu. 6. Toolbars 

7.  Project tab . 8. Pipeline tab. 9. View/Console Tab. 10. Task Tab. 11. To-Do Tab. 

12. Properties tab. 13. Results Tab. 

 

 Main Menu 

 Menu File 

  New Project - Create a new project. In "Create New Project" dialog, enter 

folder name for a new project. It will also be assigned as a name of a project 

itself. If you want to change the location of the project folder, press Browse 

button. If the project folder already exists in the current location or contains 

invalid symbols, the "OK" button in "Create new Project" dialog will be 

inactive. The project name is shown on top of the Project Panel. You can 

change the name, it does not have to match folder name or be unique. Press the 

"OK" button to confirm. A new project with the specified name has now been 

created. 

 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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 Open Project - Open an existing project. Displays "Open project" dialog. 

Choose a project folder and press the "Choose" button. The project is now 

assigned a "current project" status.  Project tab  and Pipeline tab display tasks 

of current project. 

 

 

> 

 

 Reopen Project - Reopens current project without saving any changes made 

during the session. 

 Save All - Save all projects at their current state. 

 Save Project - Save current in its current state. 

 Save project as - This command is used to create a copy of the current project. 

All tasks and their properties are copied, while outputs/results are not. 

Completed tasks change their status to "ready", states of other tasks are 

unaffected. A dialog "Save project As" is displayed. Type a unique name of a 

project copy. If name already exists or contains invalid symbols, the "OK" 

button in the "Create Project" dialog will be inactive. Valid symbols are same 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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as for Windows filenames. Press the "OK" button to confirm. The copied 

project is now the current project. 

 

 

 Close Project - Close current project. The project is saved at its current stage 

of progress and then closed. 

 Close All Projects - Close all projects. The projects are saved at its current 

stage of progress and then closed. 

 Load Projects List - Load projects from previously saved projects list. These 

projects are appended to a list of open projects (see below). 

 

 

 

 Save Projects List - Save a list of open projects. This list is also shown 

in Manager Tab. 

 Close Project without saving - Close current project without saving. Any 

unsaved changes will be lost. 

 Close All Projects without saving - Close All Projects without saving. 
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 Exit without projects saving - Close All Projects without saving and exit the 

application. 

 Exit - Save all projects in their current state and exit the application. 

 Menu Task 

 Run Task - run Selected Task. Task Status must be "Ready" or "Enabled". 

 Stop Task - stop execution of selected running task. If a task has several 

passes, it stops after current pass is copleted. This command does not stop the 

execution of a project. Other enabled tasks, if any, will be executed. 

 Abort Task - - immediately abort a task. This command does not stop the 

execution of a project. Other enabled tasks, if any, will be executed. 

 Enable Task - enable a task. Only enabled task are run when a project is 

executed. 

 Disable Task - change task status from "Enabled" to "Ready". 

 Lock Task - set the task lockup status to “locked”. 

 Unlock Task - set the task lockup status to “not locked”. 

 Lock Freeze Task - set the task lockup status to “frozen”. 

 Unlock Frozen Task - remove the frozen status from task. 

 Hide Task - remove task image from the “Pipeline” tab. 

 View Task - display task image in the “Pipeline” tab. 

 Move Up - move a selected task one position up in the list of project tasks. 

 Move Down - move a task one position down. 

 Copy Task - create a copy of selected task and its properties. Results/output 

are not copied. 

 Open Task Folder - open a folder with task output files. 

 Delete Results - delete results of selected task and resets its status to "Ready". 

 Delete Task - a task and its results. 

 Menu Project 

 Rename Project - rename selected project. Displays "Rename Project" dialog. 

 

 Run Project - run a project. Only enabled tasks will run. 

 Stop Project - stop execution of a project immediately after a task pass in 

progress is completed. 

 Abort Project - immediately abort execution of a project, not waiting until 

currently running pass is finished. 

 Enable All Ready Tasks - enable all tasks in current project. Only enabled 

tasks are run when a project is executed. 
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 Disable All Enabled Tasks - change status of all enabled tasks to "Ready". 

 Lock All Tasks - lock all tasks of the project (does not affect the frozen tasks). 

 Unlock All Tasks - unlock all tasks of the project (does not affect the frozen 

tasks). 

 Invert Locked - invert the tasks lockage. 

 Special Lock : 

o Lock All Completed - lock all completed tasks. 

o Lock All Not Completed - lock all non-completed tasks. 

o Lock All Hidden - lock all hidden tasks. 

o Lock All Visible - lock all visible tasks . 

o Lock All Enabled - lock all enabled tasks. 

o Lock All Disabled - lock all tasks without “enabled” status. 

 Special Unlock: 

o Unlock All Completed - unlock all completed tasks. 

o Unlock All Not Completed - unlock all non-completed tasks . 

o Unlock All Hidden - unlock all hidden tasks . 

o Unlock All Visible - unlock all visible tasks. 

o Unlock All Enabled - unlock all enabled tasks. 

o Unlock All Disabled - unlock all tasks without “enabled” status. 

 Hide All Tasks - remove flowcharts of all tasks of the projects from the 

“Pipeline” tab. 

 View All Task - display all tasks of the project in the “Pipeline” tab. 

 Invert Visible - invert visibility of the project tasks. 

 Special Hide: 

o Hide All Completed - hide all completed tasks. 

o Hide All Not Completed - hide all non-completed tasks. 

o Hide All Locked - hide all locked tasks . 

o Hide All Unlocked - hide all non-locked tasks. 

o Hide All Enabled - hide all enabled tasks. 

o Hide All Disabled - hide all tasks without “enabled” status. 

 Special View: 

o View All Completed - display flowcharts of all completed tasks of the 

project in the “Pipeline” tab. 

o View All Not Completed - display flowcharts of all non-completed 

tasks of the project in the “Pipeline” tab. 

o View All Locked- - display flowcharts of all locked tasks of the project 

in the “Pipeline” tab. 

o View All Unlocked - display flowcharts of all non-locked tasks of the 

project in the “Pipeline” tab. 

o View All Enabled - display flowcharts of all tasks with “Enabled” 

status. 

o View All Disabled - display flowcharts of all tasks without “Enabled” 

status. 

 Delete All Results - delete results of all tasks within a project that have been 

completed. 

 Clear Project - delete all tasks from current project. 
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 Delete Project - delete current project. 

 Menu Tools 

 Start with selected profie - If enabled, the last selected profile (see Profile 

Manager dialog) is loaded when MolQuest is started. If disabled, MolQuest 

loads at start up the same configuration in had when exited. 

 Profile manager - Displays Profile Manager dialog for changing existing 

profile settings or creating new ones. 

 Options – Displays Options dialog, which is used to control various MolQuest 

settings. 

 Panels Settings – Displays Panels dialog. 

 Property Editor Options – Displays Property Editor Options dialog. 

 Install Package - Displays "Install Package" dialog, used to install new 

programs and converters within MolQuest. Requires administrator privileges. 

 

 Install License - install a new license. 

 Viewers - run selected viewer. 

 Menu Window 

 Style - sets interface window. 

 Toolbars - chooses toolbars to display (see Toolbars). 

  Screen Shot - choosing this menu option makes a shot of MolQuest screen, 

and a dialog for saving a screenshot is displayed. A shot is saved in png format. 
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 Menu Help 

 MolQuest Help - displays MolQuest help. 

 MolQuest License Agreement - displays MolQuest license agreement. 

 Tutorials - submenu with a list of flash tutorials. 

 "Company" Main Help - displays main help for selected company (currently 

only Softberry). 

 "Company" Help Files - submenu with all help files for selected company. 

 "Company" Sample Data - open a folder with sample data for selected 

company. 

 "Company" Sample Projects - displays "Sample Projects" dialog with list of 

premade sample projects for selected company.  

 

Mouse right click calls out the contextual dialog menu: 

 

o Auto Collapse All - if checked, selecting one program group collapses 

all other program groups. 

o Collapse All - collapse all program groups. 

o Expand All - expand all program groups. If "Auto Collapse" mode is 

checked, this option is inactive. 
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o Program (Converter, Project) Help - open help for selected program 

(converter, pipeline). 

o Add to Project - добавляет все задачи из sample проекта в текущий 

проект (если он есть). 

o Create Project - сreate a project based on sample project. Displays 

"Save Sample Project As" dialog. See Save Project As. 

 

 

 

Mouse double-click adds all tasks of the sample project to the current one (if it exists). 

 Softberry Home Page - opens Softberry home page. 

 MolQuest Home Page - opens MolQuest home page. 

 MolQuest Updates - opens MolQuest Updates page. 

 MolQuest Technical Support Page - oopens MolQuest Technical Support 

page. 

 MolQuest Technical Support Mail - send an e-mail to MolQuest Technical 

Support. 

 About - displays "About" dialog. 
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 Toolbox tab 

 

1. List of distribution companies. 2. List of programs. 3. List of converters. 4. List of 

pipelines. 

Toolbox Tab is used to add a program or a converter to a project. The drop down list 

at the top of the tab contains the names of companies whose programs are included in 

MolQuest (currently only Softberry). 

The tab contains the following lists: 

  Programs list. This list contains all included programs of a given company. 

To add a task to a project, expand appropriate group and double click on a 

program name. 

  Converters list. To add a converter to a project, double click on a converter 

name. Converters are special programs for changing file formats. Unlike 

regular programs, converters can be added to a project not only by user, but 

also automatically at pipeline level (see Pipeline tab). 

  Pipelines list. Contains a list of pipeline template projects. To create a project 

from a pipeline template, double click on a pipeline name. 

Contextual menu of the Toolbox Tab contains the following commands: 
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 Auto Collapse All - if checked, selecting one program group collapses all other 

program groups. 

 Collapse All - collapse all program groups. 

 Expand All - expand all program groups. If "Auto Collapse" mode is checked, 

this option is inactive. 

 Program (Converter, Project) Help - open help for selected program 

(converter, pipeline). 

 Properties tab 

The Properties tab is purposed for setting up task parameters. The Properties 

tab contains: 

 View List 

 Property Editor - General page 

 Description page 

 Constrains page 

 Task Extras page 

 Slots setup pages 
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1. View List. 2. "General" page. 3. "In Slots" page. 4. "Out Slots" page. 4. "Task Extras" 

page. 6. "Description" page. 7. "Constrains" page. 

 View List. 

View List contains a list of predefined task's Views (see View). The contextual menu 

of View List is as follows: 

 

The contextual list menu contains the following commands: 

  Add View Copy - create a copy of current view. Displays "Add View Copy" 

dialog, where user enters a name of a new View. 
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  Rename View - displays "Rename View" dialog, where user can change a 

name of a current View. 

 

 

 

 

 Delete View - Delete View. 

 Delete All Other Views - Deletes all Views except selected one. 

 Property Editor - General page. 

Before executing a task, user has to specify all task's properties (parameters), for 

instance type and location of an input, output options, and program options: for 

instance, organism-specific matrix or codon table for FGENESH. Some tasks have 

several dozens of properties with complex dependencies. Any single property can be 

mandatory or optional. Some properties have default values. 

Property Editor handles all task properties in a convenient way. User can specify 

strings, numbers, files, lists of files, folders and other types of data as property values. 

Every property has a value, and some values are incompatible with each other. 

Property Editor checks properties for such incompatibilities or other errors, as well as 

for omissions. Properties can be nested (see example below). 

Properties are grouped in sections, which vary depending on program. The 

most common sections are following (on General page): 

 System - contains such informational properties as task name, program name 

and version etc. This section is mandatory, but filled automatically. 

 Input - includes various input properties, such as a source of input data (pipe, 

file, list of files etc.), definitions for detailed input (lists of variables or cases in 

SelTag) etc. 

 Output - includes various output properties, such as an output filename, its 

format, etc. 
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 Options - includes various task properties, such as processing modes, 

restrictions, coefficients etc. 

 Preprocessing - includes settings for preliminary processing of input data. 

 Property Icons and Property Activity 

Below is a window of Property Editor General page. 

 

 

Left column contains name of each property, right column - its value. Some of 

properties can have the following information icons next to their names: 
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 This is a system property, not defined by user. One such property is program name. 

 The value for this property is undefined or wrong. 

 
This node contains one or more nested properties, for which the values are undefined or 

wrong. 

 This property is inactive and not used by the task, so its value can't be set. 

 This property is active and its value must be set. 

 

This property is "Read only", and its value can't be changed. Unlike system property, value 

of read only property affects task results.  

A property can become "read only" either by user's choice (selection of "Property 

Permanently ReadOnly" command in contextual menu) or by such combination of values of 

other properties that allow only single value of this property. 

 
This property is disabled. If parent property is inactive or read only, nested properties are 

disabled. 

Disabled and other inactive properties are shown in grey. 

A program can have optional parameters, so some properties may be switched 

between active and inactive states by checking/unchecking the box:  / . Other 

properties are permanently active. Active properties are used by a task, inactive are 

not. 

Examples of disabled properties are below. 

 

 

"Perform gapped alignment" property is optional and set active (box is checked), its 

nested properties are "Open Gap Cost" and "Extend Gap Cost". If "Perform gapped 

alignment" property is set inactive (box is unchecked), nested properties "Open Gap 

Cost" and "Extend Gap Cost" are disabled. 

 

 

If a property is inactive, all nested properties are inactive as well, so Property Editor 

disables editing their values. 

A property is also disabled if its parent property is read only, for example: 
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If "Multiply variants……" property is set to read only, all nested properties except 

selected become disabled, and selected properties become read only. 

 

 

 Contextual menu of Property Editor 

Contextual menu of Property Editor contains the following commands: 

 Collapse All - collapse all nodes. 

 Expand All - expand all nodes. 

 Top position - go to the top of a list. 

 Copy Value - copy property value to clipboard. 

 Paste Value - paste property value from clipboard. 

 Copy Property String - copy property name and value to clipboard. 

 Open folder - open folder where selected file is located. 

 Open with text editor - оpen file using text editor. 
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 Open with viewer - file using special graphical viewer (must be installed). 

  Property - Rename - rename a property. Displays "Rename Property" dialog. 

 

 

 

 

 Property - Move Up - moves property up. Property can also be moved within 

nested group of parent property. 

 Property - Move Down - moves property down. 

 Property - Permanently Active - makes an optional property permanently 

active, i.e. mandatory. This action can't be undone in current View. 

 Property - Permanently Hide - Hides property, locking its value and activity 

status at the same time. This action can't be undone in current View. 

 Property - Permanently ReadOnly - makes property read only. All active 

nested properties also become read only, while inactive nested properties 

become disabled. This action can't be undone in current View. 

  
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List Item - Rename - Some properties have only a fixed set of acceptable 

values. For instance, genefinding parameters for FGENESH can only be 

human, mouse, Drosophila etc. This action renames one of such values chosen 

from a list, for instance user can change Drosophila to fruit fly. Displays 

"Rename Item" dialog.  

 

 

 

 List Item - Permanently Active - make a list item permanently active, i.e. 

locks property value at this list item. This action can't be undone in current 

View. 

 List Item - Permanently Hide - hides a list item permanently, i.e. deletes it 

from a list of acceptable values. This action can't be undone in current View. 

 List Item - Permanently ReadOnly - set nested properties of this list item into 

read only mode, i.e. they become unavailable for editing. This action can't be 

undone in current View. 

 SubNodes - Permanently Hide - hide children nodes. This command is 

available for radiogroups only. This action can't be undone in current View. 

Warning! All commands with "Permanently …" in their names can't be undone in the 

current View. Therefore, before taking such actions, create a copy of current View so 

that you can restore original View. Otherwise, in order to undo such actions, you'll 

have to create a new View from scratch. 

 Values of properties 

Depending on property type, values can be: 

 selected from a list 

 typed in manually 

 files selected using standard Select File dialog, which appears when the 

corresponding button in property value column is pressed. Full path is required 

for input files, for output files - filename only. Path to a file can be typed in or 

selected in Select File dialog. You can also drag and drop files or paste them 

from a clipboard. In certain cases, files can be selected from a drop down 

menu. 

For properties that define input data source, there are three possible value 

variants: File, Files list and Pipe: 
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 File - data are located in a file with user-specified path. Icon  indicates that 

specified file exists, icon  - that path or filename are incorrect, i.e. file cannot 

be located. 

 Files list - a list consisting of one or more files created in File List dialog 

(evoked by pressing  button) is used as an input. In such case MolQuest runs 

several passes, one file from a list at a time, in the same order they appear in a 

dialog window, until all files are processed. Results of each pass are shown in a 

list in Results Tab. Icon  indicates that file list is empty, while  means that 

it is not. 

 

 

In File List dialog (see picture below), pressing  button opens standard Add 

File window, which is used to add files to a list. 
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Order of files in a list can be changed by using  and  buttons. 

To remove an individual file from a list, press  button, and to remove all 

files,  button. 

 Pipe - input data are taken directly from output of another task in the same 

project. Correct link to pipe data source is indicated by icon  ,while 

undefined or wrong link - by icon  . Similarly,  icon means that 

destination for output data is correct, and the  - that link is not defined or 

incorrect. 

To choose the link for input data, use  button (Placed on In Slots page), which 

displays "Select Task Output" dialog with list of outputs of task within current project. 

Moving outputs between "Available pipes" and "Selected pipes" lists is performing by 

mouse doube-click. 
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Some properties are mutually exclusive, i.e. if value of Property 1 is set, value of 

Property 2 cannot be set. Such properties are grouped into a radio node. In such cases, 

a separator "::" is placed after a name of a node (parent property), separating it from a 

name of selected nested property. User can change this default style with alternative 

ones in Rename Property dialog below. 

For example, label "Multiply variants::Non-Overlapped variants::Number" means that 

parent property "Multiply variants" has nested property "Non-Overlapped variants" 

selected as its value, and this property "Non-Overlapped" has its own nested property, 

"Number" as its value: 
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Property Rename command in the contextual menu opens Rename Property 

dialog. If "Absolute Name" box is checked, name of selected nested property won't 

be added to node name after a separator. 

 

 

 Description page 

 

 

 

Description page contains brief descriptions of some selected properties or their 

values. 
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 Constrains page 

 

 

 

Constrains page contains requirements to values of some properties (value type, 

minimum and maximum value etc.) 

 Task Extras Page 

 

 

 

Additional task run settings. 

In the "Task Extras" page the following parameters can be specified: 

 Multiplicate Input 

 Processing Events 
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 Multiplicate input 

 

 

 

Multiplicate Input - the way to combine input data. The current option makes sense 

for the programs with two or more data inputs and can be enabled ("Yes", set by 

default) or disabled ("No"). 

Yes - on putting multiple data (list of files or pipeline multiple output data) to a 

program entries, all possible combinations of input data are to be checked. For 

example, to the first entry the list of 3 files and to the second one - the list of 4 files 

are set, then 12 different results will be at the end:  

 

1 variant - the first file from list one and the first file from list two;  

2 variant - the first file from list one and the second file from list two;  

3 variant - the first file from list one and the third file from list two;  

4 variant - the first file from list one and the fourth file from list two;  

5 variant - the second file from list one and the first file from list two;  

....  

12 variant - the third file from list one and the fourth file from list two; 

Priority of slots can be specified in the "In Slots" tab. 

No - consecutive combinations are to be used only. The number of results is 

determined by the the smallest data input. For example, to the first entry the list of 3 
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files and to the second one - the list of 4 files are set, then 3 different results will be at 

the end:  

 

1 variant - the first file from list one and the first file from list two;  

2 variant - the second file from list one and the second file from list two;  

3 variant - the third file from list one and the third file from list two; 

See more at Input Slots>Multiplicate Order 

 Processing Events – processing of task run events 

Reactions on the following events can be specified: 

 On Empty Slot Data — This event occurs on empty data received by, at least, 

one output slot at the current pass. For the file data it means no file or empty 

one. 

 On Empty Pass Data — This event occurs on empty data received by all 

output slots at the current pass. 

 On Pass Warning — This event occurs on completion of the current pass with 

warning. On pass warning — warning is received during the current pass.  

 Note. This event does not occur on explicit warning generation by the 

"Generate Pass warning" operation (see "Actions" section). 

For these events the followings are possible: 

 Emit internal signals — To generate internal signals (see "Emit internal 

signals" section). ; 

 Do Actions — To perform the chosen actions. The possible types of action – 

actions for the input slots and service ones. 

 Slots setup 

 Output slots setting up - Out Slots page 

 Input slots setting up - In Slots page 

 Output Slots setting up 

 Out Slots page 

The page allows to set up the parameters of the task output slots working.  

To enable the additional options on the slot working, check in the box next to the slot 

name. 
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 Visible 

If the "no" value is selected, the slot with its links is not displayed on the task image 

in the "Pipeline" tab. If the "yes" value is selected, the slot with its links is displayed 

on the task image in the "Pipeline" tab. 

  

 Processing Events – processing of the events on output slots 

For the output slot the reactions on following events can be specified: 

 On Empty Slot Data - This event means empty data receiving by the slot. For 

the file data it means no file or empty one. The possible reactions to this event 

are: 

o Emit internal signals — To generate internal signal(s). 

o Do Actions — To perform the chosen actions. The possible types of 

action – actions for the output slots and service ones.). 

 Input slots setting up 

 In Slots page 

The page allows to set up the parameters of the task input slots working: 

• Cyclic 

• Multiplicate Order 
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• Pipes 

• Visible 

• Use Static Data 

• Switching Pipes (By) 

• Switching Pipes Order 

• Accept 

• Processing Events 

• Processing Signals 
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 Cyclic 

Cyclic – to «cycle» the data processing at the slot. All incoming data will be 

processed repeatedly ad infinitum. This mode is independent on settings of other task 

slots (slots priority, for example). 

 Multiplicate order 

Multiplicate order - sets the priority of slots at multiplicative processing. The mode 

of multiplicative processing can be enabled in the "Task Extras" page. 

If the multiplicative processing is disabled, the priorities have no significance. 

 Priorities definition. 

For all slots, the priorities are specified explicitly and can not be equal. If values 

specified in the Multiplicate order are equal, the higher priority belongs to a slot that 

is lower in the list. If values differ, the higher priority belongs to a slot with higher 

value. 

 Slot processing order in dependance on priority. 

The data at slots with higher priority are being iterated primarily. E.g. if data from the 

first slot have a lower priority than that from the second one, the processing will be 

performed in the following way:  

1st element of the 1st slot is being processed with all elements of the 2nd slot, 2nd 

element of the 1st slot with all elements of the 2nd slot, etc. 

 Main and auxiliary slots. 

Besides priority there is the concept of main and auxiliary slots. 

On a vector data processing (Multiplicate Input = "no") all slots are referred to as 

main. 

On multiplicative data processing (Multiplicate Input = " yes") the main slot is that 

with the least priority. All other slots are auxiliary. 

Data processing on main and auxiliary slots by default is being performed in the 

following way: 

For the main slot. Data in slots are being processed sequentially, i.e. on reaching the 

end of queue, the automatic switch to the next queue occurs. 

For the auxiliary slot. On reaching the end of queue, the automatic switch to the 

beginning of the same queue occurs. 

The way of slots processing can be changed manually by a number of settings. 
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 Pipes 

Pipes — the  button calls out the dialog for the pipes selection "Select Task 

Output", that allows to specify the project tasks output slots that will be used as input 

ones for the current slot.  

"Select Task Output" dialog contains list of outputs of task within current project. 

Moving outputs between "Available pipes" and "Selected pipes" lists is performing by 

mouse double-click or by arrows  and . Order of slots in the list can be 

changed by arrows  and . Any output slots can be selected, including the one 

of the own task. The  button clears all data of the "Selected Pipe" list. 

 

 

 

 Visible 

Visible. If the "no" value is selected, the slot with its links is not displayed on the task 

image in the "Pipeline" tab. If the "yes"" value is selected, the slot with its links is 

displayed on the task image in the "Pipeline" tab 

 

 Use Static Data 
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Use Static Data — If the "yes" value is selected, then the data corresponding to the 

slot at the "General" page (so called "Static data") are being included in the list of data 

to be processed. "No" - the data only from pipes linked to the current slot are being 

included in the list of data to be processed. If the "yes" value is selected, but no static 

data are specified at the "General" page, then the error message appears in front of 

page name. If "no" value is selected, but no pipes (so called "dynamic data") are 

linked to the slot at the "In Slots" page, then the error message appears in front of 

page name. 

 

 

 

 

 Switching Pipes (By) 

Specifies the pipes switching method: 

 Complete Queue - - switch to another pipe occurs on the "Complete Queue" 

event (that, for example, occurs at receiving the "Complete Queue" flag by the 

slot). 

 Complete Pipe - switch to another pipe occurs on the "Complete Pipe" event 

(that, for example, occurs at receiving the "Complete Pipe" flag by the slot).  

 Note. If switching from pipe to pipe takes place, the "Complete Pipe" event is 

being generated independently on switching method. 

 Switching Pipes Order 

Species the pipes processing order: 

 By accessibility - – Pipes are being processed in the order that specified in the 

"Selected Pipes" list in the "Select Task Output" dialog. On reaching the end of 

list, the processing continues from its beginning. In the case, when it's 

necessary to switch a pipe, but there are no unprocessed data on the current 
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one, the process switches to the next pipe. If there are unprocessed data, 

switching is completed and processing of these data begins. If there are no data, 

switching to the next pipe in the list occurs, and so on until the appropriate pipe 

is found. If no appropriate pipe is found, switching is considered uncompleted. 

It will be completed when unprocessed data emerged on any pipe of the list. 

This processing order is used by default. 

 Strict Order - Pipes are to be processed strictly in the order they are in the 

"Selected Pipes" list of the "Select Task Output" dialog. Switching occurs to 

the next pipe by the order. If pipe, to which the switching has been done, 

contains no unprocessed data, the processing goes to stop until such data 

emerge. After the end of list is reached, the processing begins from the start of 

list round. 

 

 

 

 Accept 

Accept — which data slot can accept: 

 All — all incoming data. 

 Last In Queue — just the last data item in the line. In the case of static data 

only are used by slot, the mode does not work, i.e. processing of all static data 

item s will be performed. To perform the processing of the single element is 

always possible by its direct definition, e.g specifying the single file instead of 

list of them. 

 Processing Events 
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The reaction to the following events can be specified: 

 On Complete Queue — may occur on: 

o Finding the marker of the queue end 

o Reaching the end of static data list, in the case of dynamic data (data 

from pipes) absence 

o On explicit event generation at performing of certain actions  (see Do 

Actions section, actions for input slots). 

 On Complete Pipe — may occur on: 

o Finding the "On Complete Pipe" marker. 

o On any switch necessity specified at "Switching Pipes (By)" 

o On explicit event generation at performing of certain actions(see "Do 

Actions" section, actions for input slots). 

For these events the following can be done: 

 Emit internal signals — To generate internal signals. 

 Do Actions — To perform selected actions. The allowed action types – actions 

for input slots, actions for output slots and service actions. 

 Processing signals 

Input slot can process the received signals. 

In the node "On Signals" in the line "If Signals Match Expression" the logical 

expression of signal names can be specified. The following symbols are allowed the 

logical expression: "&", "|", "!" as well as grouping by brackets "(" ")". 

On completion of pass, to the input slots signals from various sources arrive. 

Processing occurs if the "On Signals" checkbox is checked in. If a signal with a 

certain name has arrived, it's being assigned with "true" value, if has not arrived - 

"false". After this, the logical expression is being checked for validity. If it's valid, the 

actions specified in the "Do Actions" node are being performed. 

 Emit internal signals 

To enable this option, check in the box next to the name "Signals Values" and fill in 

the field. In the field the one or several signals can be specified. Signals can be 

separated by symbols " ", "," or ";". The signal value can be specified in Latin 

symbols (case sensitive) in both cases, numerical symbols and underlines. Excessive 

separators are being ignored. 

Signals are being sent within the task only. Any signal is being sent to all input task 

slots. 
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 Do Actions 

Actions can be performed for various events and on signals processing. To make 

action to be performed, set the "yes" value in front of its name in the list. For some 

events not all actions are declared, since they are either not related to current event 

type or their performing has no sense. There are 3 various action variants: for output 

slots, "service" and for input slots. 

 Service actions. Can be performed for any event and on signals processing. 

o Turn Off Task — To remove the "ready to run" status from the task in 

the "Projects" tab. At this, the task is being turned off until user set it on 

again. 

o Stop Project — To stop the project. At this, the project is being turned 

off until user set it on again. 

o Generate Task Warning — To generate the warning of pass 

completing. The current pass is being marked with  status in the 

"State" column of the "Results" tab (if it was not before). 

o Generate Task Error — To generate the error of pass completing. In 

the "State" column of the "Project" tab, as well as in the "Results" tab, 

the  status will appear. Data of the pass with error are not to be sent to 

pipe. 

 Actions for the output slots 
o Complete Out Queues — To add the "Complete Queue" flag, that 

means the end of queue, to a corresponding element of data stream 

(relevant to current pass) for every output slot of the current pass. For 

this pass, in the "Flags" column of the "Results" tab, the "Q" sign will 

appear. 
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o Complete Out Pipes — Do the same as "Complete Out Queues". 

Besides it, for every output slot of the current pass the "Complete Pipe" 

flag, that means the necessity to switch to the next pipe, is being added 

to a corresponding element of data stream (relevant to current pass). For 

this pass, in the "Flags" column of the "Results" tab, the "QP" sign will 

appear. 

 

 

 

 Actions for the input slots. These actions control the queues processing at the 

input slot. 

o Complete Queue Completes the queue at the current position. Adds the 

"Complete Queue" flag to current element. In addition, the completing of 

this action generates the "On Complete Queue" event. 

o Complete Pipe Do the same as "Complete Queue". Besides it control 

the switching to another pipe in accordance to switch settings (see here). 

In addition, the completing of this action generates the "On Complete 

Pipe" event. 

o Clear Queue – Clear the queue (all data in queue are considered to be 

processed). If it's possible to determine the end of queue by the flag in a 

pipe, the switching to the next queue occurs. If the end of queue can not 

be currently detected, the switching to behind the end of data list occurs 

and at the last element the flag of queue end is being set. The completing 

of this action generates the "On Complete Queue" event. 

o Next Queue – To switch to the next queue. The switching occurs only in 

the case of next queue existing. If currently there is no flag of the queue 

end, the system remains at the current queue. If switching to the next 

queue occurs, the "On Complete Queue" event is being generated. 

o Reset Pipe Queue — To set the processing position in the current queue 

to the beginning of data by pipe. 
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o Reset Static Data — To process static data in the current queue over 

again. 

 Order of actions performing for input slots. 

Logical order of actions performing is strictly the same as in description. The only 

exception is part of "Complete Pipe" action – the switching to another pipe. It's being 

performed just after completion of all other actions. I.e. all actions are being 

performed for current pipe and just after this, on necessity, the switching to another 

pipe occurs. The same for switching to another pipe due to other settings ("Switching 

Pipes By" for example). 

  Project tab  

 Project tab  contains a list of tasks in a current project: 

 

 

 

N - the order number of each task. 

E - displays the current Ready State. 

Res/State - displays the current Execution State(s) of a task. 

V (Visibility) - Displays the current status of task visibility. 

L (Locking) - Displays the current status of task lockup. 

Run - displays the current Running State of a task. 

In - displays source of Input Data. 

Out - displays destination of Output Data. 

ID - displays unique ID of a task in a project. 
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Task Name - displays the name of a task. 

Pass - displays number of completed passes / total number of passes. 

Results column contains shortcuts to task results (output):  

 - Results Folder - opens a folder with output files and log files.  

 - Results File - opens "text/plain" file containing task output, if not empty. If this 

icon is shaded:  , MolQuest can't find text viewer for this "text/plain" file.  

 - Results Files - opens nonempty "text/plain" files containing task output. This 

icon appears instead of the Results File (  ) icon if more than output file was 

generated by a task. Shaded icon  indicates that either multiple passes resulted in 

creation of several sets of output files, which can be viewed in Results Tab, or 

MolQuest can't find a viewer for these files  

 - opens output in a graphical viewer. MolQuest has multiple graphical viewers for 

many output file formats.  

 - more than one output file is available for viewing with graphical viewers.  

 - multiple passes resulted in sets of output files. 

Processing - time it took to process task. 

Last Start Time - last time when task started. 

 Task Status 

 Ready State 

This is a status of task's readiness for execution: 

 
Not Ready. Some required properties are not defined and/or some of their values 

are set incorrectly. 

  Ready. All required properties were defined. 

  
Enabled. This task will be run during the execution of a project or the task is 

completed. 

 Execution State 

This is current execution status of a task. Move the mouse cursor over a status icon to 

display details. 

  The task has not been started. 

  Completed. The task was completed without errors or warnings. 

  

Completed with Warnings. Some warnings or errors occurred during task 

execution, and at least one pass has finished without errors. Put a mouse over the 

icon to see a diagnostic message. Сlick the shortcut in Results column to open a 

log file. 

  
Completed With Error. There are no passes that finished without errors. Every 

pass of the task were been executed with errors. A task has no meaningful results 
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to use or to send to a pipeline. Put a mouse over the icon to see a diagnostic 

message. Сlick the shortcut in Results column to open a log file. See also Results 

Tab for more information. 

  Program Expired. Program Evaluation period is expired. 

 Visibility Status 

The visibility status switches the task display in the “Pipeline” tab. 

 View Task. Make task visible in the "Pipeline" tab. 

  Hide Task. Make task invisible in the "Pipeline" tab. 

 

Visibility status can be switched by: 

 Mouse click over visibility status icon in the "V" column of the "Project" tab. 

 Main menu commands: 

Task: 

 Hide Task 

 View Task 

Project: 

 Hide All Tasks 

 View All Tasks 

 Invert Visible 

 Special Hide 

 Special View 

 Task lockup status 

  Task is not locked. 

  Regular task lock. 

   Task is Frozen. 

 

Lockup status is duplicated at task icon in the "Pipeline" tab. 

 

A task can be both regularly locked and “frozen”. 

 

Regular lockup means the locked task is not to be processed, task parameters can not 

be edited (excluding addition/removal pipe-links), execution flag can not be set, data 

can not be removed. Task can be deleted. 

 

"Frozen" lockup does the same, but, in addition, it makes the following commands 

inactive: Lock All Tasks, Unlock All Tasks, Invert Lock and Special Lock/Unlock. 

 

Lockup statuses can be switched by: 

 mouse click over appropriate icon in the "L" column of the "Project" tab. 

 mouse click over appropriate icon at task image in the "Pipeline" tab. 
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 commands of the main menu: 

Task: 

 Lock Task 

 Unlock Task 

 Lock Freeze Task 

 Unlock Frozen Task 

Project: 

 Lock All Tasks 

 Unlock All Tasks 

 Invert Locked 

 Special Lock 

 Special Unlock 

 Running State 

 In Progress. The task is being run now. 

  
Aborted. User aborted a task on the first pass. No results to use or to send to a 

pipeline. 

 

At the task image in the "Pipeline" tab, the information of the "E", "Run" ("Run" 

status only) and "L" columns is duplicated. 

 

 Input Data 

If a task is part of a pipeline, state of input data is displayed here.  icon means that 

a task uses an output of one pipe as input data,  means that it uses more than one 

input pipe. Shaded icons (   ) mean that all input data are ready but are not 

currently in use by other task, blue symbols (   ) mean that input data are 

currently being used by running task, red symbols (   ) mean that some data are 

not ready. 

 Output Data 

This column has the same meaning as the "Input Data" column, but for output data of 

a task. 

 Toolbars 

MolQuest has three toolbars: Project, View/Console, Configuration. 
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 Project toolbar 

Project Toolbar contains buttons for work with projects and tasks, which have the 

following functions: 

 Same as: Project->Run Project in Main Menu. 

 Same as: Project->Stop Project in Main Menu. 

 Same as: Project->Abort Project in Main Menu. 

 Deletes all Tasks from Project. 

 Same as: Project->Delete All Results in Main Menu. 

 Same as: Project->Enable All Ready Tasks in Main Menu. 

 Same as: Project->Disable All Enabled Tasks in Main Menu. 

 Same as: Task->Open Task Folder in Main Menu. 

 Same as: Task->Copy Task in Main Menu. 

 Same as: Task->Delete Results in Main Menu. 

 Same as: Task->Delete Task in Main Menu. 

 Same as: Task->Run Task in Main Menu. 

 Same as: Task->Stop Task in Main Menu. 

 Same as: Task->Abort Task in Main Menu. 

 Same as: Task->Move Up in Main Menu. 

 Same as: Task->Move Down in Main Menu. 

 Evokes help cursor. Point it to a window object and click to get help. 

 View/Console toolbar 

View/Console toolbar has buttons for work with View/Console Tab. 

 
Same as "Activate View/Console" in dialog Tools->Options->View/Console in 

Main Menu. 

 
Same as "Show Results" in dialog Tools->Options->View/Console in Main 

Menu. 

 
Same as "Show warnings" in dialog Tools->Options->View/Console in Main 

Menu. 

 Same as "Show errors" in dialog Tools->Options->View/Console in Main Menu. 

 
Same as "Console Mode" in dialog Tools->Options->View/Console in Main 

Menu. 

 
Same as "Wrap by View Width" in dialog Tools->Options->View/Console in 

Main Menu. 

 
Same as "Column Selection Mode" in dialog Tools->Options->View/Console in 

Main Menu. 
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Same as "Show Left Ruler" in dialog Tools->Options->View/Console in Main 

Menu. 

 
Same as "Show Top Ruler" in dialog Tools->Options->View/Console in Main 

Menu. 

 Reopen current file in View/Console Tab 

 Configuration toolbar 

 Same as: Tools->Profile Manager in Main Menu. 

 Chose profile from a list and make it current. 

 Results tab 

This tab shows a list of all passes for selected task, with their states. 

For many programs, a list of files can the set as an input, in which case each file from 

a list will be processed by a separate pass of a program. If a task has more than one 

property set as a list of files, different combinations of files will be processed. For 

instance, if Property 1 is specified as a a list containing three files, and Property 2 as a 

list of four files, there will be 4 x 3 = 12 passes (if Multiplicate Input option is 

enabled), each one combination of input files. if Multiplicate Input is disabled, the 

number of passes is determined by the the smallest data input. For instance, if 

Property 1 is specified as a a list containing three files, and Property 2 as a list of four 

files, there will be, then 3 passes. Total number of passes for one task cannot exceed 

100,000. 
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The column in Results tab have the following meaning: 

 Pass - an order number of current pass; 

 State - pass status: 

o  - in process; 

o  - completed without errors or warnings; 

o  - completed with warnings; 

o  - completed with errors; 

o  - aborted. 

 Flags - display pass flags (if any). "QP" - means "Complete Pipe" and 

"Complete Queue" flags. "Q" means "Complete Queue" flag. "QPD" means 

"Data End" flag – the end of data is found for the current task at the current 

pipeline configuration. Simultaneously with this marker the End of Queue (Q) 

and the End of Pipe (P) markers are being set. 

 View - view results. Icons have the same meaning as those in Results column 

of  Project tab , but for current pass only. 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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 Processing - pass processing time; 

 Start time - pass start time. 

For a pass selected in Results tab, the following information is displayed: 

In the Input Files page, input files that were used by current pass: 

 

Type - source of file: 

  - file, 

  - pipeline. 

View - preview input files. Icons are the same as those in Results column of Project 

tab , but for current pass only. 

File - path of an input file or pipe identifier. 

In the Output Files page, a list of output files with their status and shortcuts to 

preview: 

 

Type - possible output variants: 

  - Normal results file; 

  - Warnings log file; 

  - Errors log file. 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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View - preview results. Icons are the same as those in Results column of  Project tab , 

but for current pass only. 

File - name of output file. 

 Pipeline tab 

The Pipeline Tab is intended for viewing and editing of MolQuest projects as block 

diagrams. It provides convenient way for creating pipelines, where output data 

generated by one task is used as input data for another task. 

 

 

In Pipeline tab, every task or converter in a project is shown as a box, with task name 

underneath, input slots, representing input data, in left half of a box, and output slots 

in its right half. Moving mouse pointer over a slot displays a name of property 

corresponding to that slot. Boxes can be moved and resized, and slots can be moved 

and rearranged within their box halves. Selecting a task in Pipeline tab also selects it 

in   Project tab , and vice versa. In Property tab you can view and edit properties of a 

selected task. 

If output data of one task is used as input for another task, corresponding output and 

input slots are linked by a line. An output slot can have several outgoing links; an 

input slot can have only one incoming link. To link tasks, click on slot, move pointer 

to a slot of another task, and click there. Clicking on a first of two slots to be linked 

enters mouse pointer into linking mode. In this mode, a pointer turns yellow when 

between slots, and is followed by a yellow line, it becomes green on slots that are 

permitted to be linked, and red on slots that can't be linked. To exit linking mode, 

click anywhere outside slots. 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
file:///C:/Program%20Files/Softberry/Molquest2/help/gui/3.14-ProjectTab.html
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You cannot link tasks if: 

 You are trying to link input to input or output to output. 

 An input slot belongs to a task that is currently running or has been completed. 

Slots setup see here. 

Completed link assumes various styles and colors depending on compatibility of 

formats of linked output and input. Light gray solid line means that input and output 

data formats are compatible without using a converter. Light gray dotted line means 

that input and output formats are compatible after using a converter that was 

automatically selected by MolQuest (so-called implicit converter) and included in a 

project, implicit converters are not shown as separate tasks. If MolQuest cannot 

automatically select a converter, the line is shown as solid dark gray. If user adds a 

converter to a project (explicit converter), it must be inserted between two 

corresponding tasks, and is shown in Pipeline tab as a task. Lines to/from explicit 

converter are shown in blue. If one or both linked slots are inactive, the link is shown 

as a dashed line. Pipelines containing formats judged by MolQuest as incompatible, or 

containing explicit converters, can be run, but user has to be sure that he can get 

meaningful results. 

  Formats for input and output data are compatible. 

  Formats are incompatible, but converter is found and added automatically. 

  
Formats for input and output data do not match and MolQuest cannot automatically 

find an appropriate converter. 

  
Formats do not match selected converter (will be shown for explicit converters 

unknown to MolQuest). 

  
The format of input file is a subset of a format of output file. For example: Input file 

format is "Fasta", output file format is "Multifasta". 

To delete a link, click on its input. You can't delete input links of running or 

completed tasks. To delete tasks or converters, use  Project tab . To edit task 

properties, use the Properties tab. To add new task or converter, use Toolbox Tab. 

Properties of a completed task cannot be edited. If you want to alter some properties 

and preserve task results, use Task->Copy Task command in the main menu and edit 

properties of a task copy. 

On placing the mouse pointer over the task at hold “Shift” key, in the tab will be 

displayed only those pipe-links, that belong to current task. 

During the task processing, the currently used pipe is highlighted by red in the 

“Pipeline” tab. 
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 Repository tab 

User may want to create libraries of tasks and projects, to be used as templates and 

building blocks for creating new tasks/projects. MolQuest has a repository which can 

be used for such purpose: Projects (Projects page) and Tasks (Tasks page) with user-

defined properties can be saved in Repository tab. 

 Task page 

 

 

 

This page contains a list of user-defined groups, each of which can include a number 

of tasks. Groups can be created, deleted, renamed, or their content can be changed 

using contextual menu commands. 

 

 

 

 Auto Collapse Groups - if checked, collapses all groups except selected. 

 Collapse All - collapses all program groups. 

 Expand All - expands all program groups. 

  Rename Group - displays "Rename Group" dialog. 
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 Delete Group - remove selected group from a list. Warning! All tasks in that 

group are deleted as well. 

  Rename Task - displays "Rename Item" dialog, in which selected task can be 

renamed. 

 

 

 

 Delete Task - removes selected task from a group. 

  Add New Group - - displays "Add New Group" dialog. 

 

 

 

 Add Current Task - Displays "Add Task" dialog, where selected task from a 

current project can be added to a group. Clear Input: if checked, all input 

values are erased. 
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 Projects page 

 

Projects page contains a list projects grouped into user-defined groups. As on tasks 

page, groups can be created, deleted, renamed, or their content can be changed using 

contextual menu commands: 

 

 Auto Collapse All - if checked, collapses all groups except selected. 

 Collapse All - collapses all program groups. 

 Expand All - expands all program groups. If "Auto Collapse" mode is active, 

only group is expanded. 

 Rename Group - "Rename Group" dialog, similar to that of Tasks page. 

 Delete Group - Deletes selected group and all projects it contains. 

  Rename Project - displays "Rename Item" dialog fro renaming selected 

project. 
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 Delete Project - removes selected project from a group. 

 Add New Group - displays "Add New Group" dialog, similar to that of Tasks 

page. 

  Add Current Project - Displays "Add Project" dialog for adding current 

project to a selected group. Clear Input: If checked, all input data are deleted, 

but pipeline links remain in place. 

 

 

 

To load a project from repository, click on it. "Save Project As" dialog will be 

displayed, where you can type project name and title and choose location for it to be 

saved in. 

 

 

 

 

 

 Manager tabManager tab contains a list of opened projects. Projects can be 

dragged by a mouse up and down in a list. Click on a project name to switch to that 

project. 

 Comments page contains some comments on selected project. 
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 Options page contains options which are applied to passes of the whole 

project: 

o Pass Priorty Run Order - when enabled, the project independently on 

options set in the tabs is being processed in the following way: the first 

pass of the first task is processed, then the first pass of the second task 

etc. Once the first pass of the last task is completed, the second pass of 

the first task is getting processed, then the second pass of the second task 

and so on. 

o Pass Sleep Interval - retardation between the ending of current pass and 

starting of the next one in milliseconds. 
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Contextual menu commands of Manager tab: 

 Rename Project - displays "Rename Project" dialog. 

 

 New Project - Displays "Create new Project" dialog, where you can enter a 

folder name for a new project, as well as choose its location. If project folder 

with the same name already exists in chosen location, or contains invalid 

symbol (those not allowed in Windows filenames), the "OK" button is 

inactivated. Entered folder name is automatically assigned as a title of the 

project, which is shown on top of Project Panel. You can change a title, it 

doesn't have to match to the folder name or be unique. 



 

 

60 

 

 

 Open Project - displays the "Open Project" dialog for opening and existing 

project. After opening, a project assumes a status of current project. 

 

 Reopen Project - Reopens current project without saving any changes. 

 Save All - Saves all projects at their current stage of progress. 

 Save Project - Saves selected project at its current stage of progress. 

 Save project as - displays the "Save Project As" dialog, used for copying all 

tasks of selected project, as well as their properties, if defined, into a new 

project. Tasks results are not copied, completed tasks switch their states to 

Ready, states of other tasks are unaffected. Fields in "Save Project As" dialog 

are the same as those in "Create New Project". 
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 Close Project - The project is saved at its current stage and closed. 

 Close All Projects - All opened projects are saved and closed. 

  Load Projects List - Load projects from previously saved projects list using 

"Load Projects List" dialog. If Manager Tab currently contains any projects, 

loaded projects are appended to it. If a project was deleted, it is automatically 

removed from all lists. 

 

 

 

  Save Projects List - Save the list of currently opened projects, i.e. those 

displayed in Manager Tab. 
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 Run Project - runs a project. Only enabled tasks will run. 

 Stop Project - stops execution of a project upon completion of currently 

running task. 

 Abort Project - immediately aborts a project, without waiting for running task 

or its pass to complete. 

 Enable All Ready Tasks - enables all Ready tasks in a project. 

 Disable All Enabled Tasks - changes status of all Enabled tasks to Ready. 

 Delete All Results - deletes results of all completed tasks. 

 Clear Project - deletes all tasks from a project. 

 Delete Project - deletes current project. 

 View/Console tab 
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View/Console displays output of a pass selected in Results tab (by default - first pass), 

if such pass resulted in an output. Selecting and copying text in this window is limited 

to visible lines. Vertical scrolling removes text selection. 

 Task tab 

 

 

 

The Task tab contains certain information about selected task and consists of 

two pages: 

 Comments - User comments on a task. 

 Quick help - Short program help. 

 To-Do tab 

 

 

 

To-Do tab represents a list of items and serves as a scratchpad or to do list. An item 

can be added by double-clicking on empty line or from contextual menu. It can be 

changed by double-clicking on an item or from contextual menu. 

The C column displays status of item completion, 

The ! column indicates item priority; 
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Category - item category; 

Caption - item name; 

Date Add - and time of item creation; 

Date End - date and time of completion. 

 

 

 

Contextual menu has the following commands: 

Add - displays "Add To-Do Item" dialog with fields corresponding to columns 

mentioned earlier on this page, plus commentary field which provides commentary on 

an item. 

 

 

 

Add Copy - adds a copy of existing item to a list. Displays "Add To-Do Item" dialog 

which already has fields pre-filled with properties of copied item. 
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Edit - edits an item; 

 

 

 

Delete - deletes an item; 

Show Completed Items - - displays/hides completed items; 

Show Full Time - - if checked, displays time and date, otherwise date only; 
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Save As XML - saves a list in a file in Unicode XML format; 

 

 

 

 

Sort - sorts items by one of the following criteria: 

  Completed 

  Priority 

  Category 

  Caption 

  Date Add 

  Date End 

Items can also be sort by clicking on corresponding column header. 

 Status Bar 

 

 

 

 

Status Bar displays the following information. 

Resource usage: 

 CPU Usage: - CPU percentage usage. 

 Memory Usage: - percentage of memory used. 
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 Free: - amount of free available memory. 

Project status: 

 Project not specified - no project is opened. 

  N - Projects in progress - the number of projects running. 

 Profile manager 

 

Profiles are designed for fast switching between different MolQuest settings. Profiles 

can include common application parameters (see Options dialog) window sizes, tabs 

location, headers sizes etc. 

"Profile Manager" dialog allows changing profiles or creating new ones. Profile 

named "Current" contains MolQuest settings currently in use. 

Pressing Copy button creates a copy of selected profile, Rename button renames a 

profile, and Delete button deletes it. 

To create a new profile, select an existing one, create a copy and then edit it. Profile 

containing current MolQuest window and options setting always exists with name 

"Curent". 

 

To create a new profile, select an existing one, create a copy and then edit it. Profile 

containing current MolQuest window and options setting always exists with name 

"Curent". 

Main Window/Panels Settings - determines window sizes, tabs location, headers 

sizes etc.  

If checked, a profile sets window/panel parameters. If unchecked, a profile doesn't set 

these parameters. If current sizes of windows and panes differ from those of current 



 

 

68 

 

profile, Setup button is enabled. Pressing it saves current settings in current profile, 

and Setup button becomes disabled again. 

Options Settings - determines common application parameters.  

If checked, a profiles common application parameters, if unchecked, a profile doesn't 

set them. "Setup" button displays Options dialog, where common application 

parameters can be changed. Checkboxes in Options dialog have three possible states: 

usual on  and off  and also unchanged , meaning that current setting doesn't 

change by changing profiles. 

 Panels dialog 

There are four zones (panels) in MolQuest main window, each containing various 

tabs: Left, Right, Center and Bottom: 

 

Panel boundaries can be moved by a mouse. 

Panels dialog is a convenient tool for rearranging tabs in the main window. Drag a 

tab name to a zone where you want it to be located. If you want to hide a tab, drag its 

name to an "OFF" group. 
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 Property Editor Options 

This dialog controls some visual and dynamic parameters of Property 

Editor settings, which de don't describe here in details. Pressing Default button resets 

all options to default. There are tow tabs - Misc and Offsets. You can return to initial 

options with the Default button. 

 Misc tab 
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 Offsets tab 

 

 
 

 Options 
 

Options dialog is displayed by choosing Tools>Options from Main Menu and is used 

to view or change various MolQuest settings. It has six tabs: 

 Prompts 

 System tray 

 Misc 

 Projects 

 Memory 

 View/Console 

 Prompts tab 
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Sets operations for which confirmation prompts will be displayed: 

 Before deleting a task 

 Before deleting task results 

 Before aborting a task 

 

 Before deleting a repository task 

 Before deleting a repository project 

 

 Before deleting a project 

 Before deleting project results 

 Before aborting a project 

 Before cleaning a project 

 

 Before deleting a to-do item displays a confirmation prompt before deleting 

an item from To-Do list. 

 System Tray tab 
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Enable system tray - MolQuest icon is displayed in the system tray. 

Minimize to system tray - MolQuest main window is minimized to the system tray. 

Clicking it restores main window. 

Show project complete hint - Once the project is finished, a message "Project 

complete "Project name"" is displayed in one of the following cases: 

 Never 

 Application minimized 

 Application not active 

 Always 

Auto hide interval (sec) - Project completion message disappears after specified 

time. 

 Misc tab 

Highlight CPU usage bar - check to display percentage of CPU usage in graphical 

form and as a number. If unchecked, only a percentage number is displayed. 

Show Grid in pipeline editor - check to show gridlines in pipeline editor. 

Show splast information window - check to show splash window on a single project 

open/close. 
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 Projects tab 

 

 

 

Contains Project settings. 

Open last projects at start-up - check to make MolQuest open at startup all projects 

that were open at the end of last session. 

Update project Input/Output data - Makes MolQuest check that all 

necessary input/output files are available (exist and are readable). If any of 
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them are unavailable, it is displayed in Results Tab, Output Files 

Sheet and/or Input Files Sheet. 

 On load project - files are checked when a project is loaded. 

 On change project - - when projects are switched in Manager Tab. 

 On application activate - every time MolQuest becomes current application. 

 Memory tab 

 

 

 

Settings of monitoring system memory. 

Memory used exceeding - if checked, displays the warning on a Status bar, if percent 

of memory used exceeds preset percentage threshold. 

 

 

 

Free memory less than - if checked, displays the warning on a Status bar, if free 

memory falls below preset threshold in MB. 

 View/Console tab 

Contains View/Console Tab settings. 

 Activate View/Console - activate/deactivate View/Console Tab. 

 Show Results - show result files of a chosen task on View/Console Tab. 

 Show Warnings - show warning files of a chosen task on View/Console Tab. 

 Show Errors - show error of a chosen task on View/Console Tab. 
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 Console Mode - If checked, all output data are displayed in real time in a 

console while a task is running. 

 Column Selection Mode - switch between column and line selection modes. 

 Wrap by View Width - wrap lines in View/Console Tab window. 

 

 

 

 

 Show Left Ruler - display left-side ruler with line wrap symbols, if exist. 

 Show Top Ruler - display top-side ruler on top of window. 

 Absolute Wrap - forces wrapping lines larger than 4096 characters. Applicable 

only to files <1 MB in size, as larger files are always force wrapped. 

 Tab Width - sets tab width. 

  Font - pressing Setup button opens a font selection dialog. Selected font must 

be of fixed width, though a dialog shows all fonts. 

 Reopen Mode - applicable only if console mode (see above) is off. Sets mode 

of refreshing displayed output file: No - not refershed; Auto - automatically 

refreshed; Message - when file is changed, asks user whether to refresh. 

 Templates 

User can integrate console applications into MolQuest GUI shell on his own. To do 

this, add "Standard Template" task from Templates group of Programs list of Toolbox 

Tab. In this template, name and path to an executable file, as well as its running 

options (input and output files, command line options and other necessary 

information) have to be specified. 

In drop down list at the very top of Properties tab , maximum allowable number of 

input files (NN Input), output files (NN Outputs) and command line options (NN 
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Options) has to be specified.. For example, "01 Input; 01 Output; 05 Option" means 

that application can have no more than one input file, one output file and five 

command line options. Once a program is added, all unused properties can be hidden. 

Template properties include the following sections: 

 System - contains the information on template and task names, and task ID; 

 exe - selects executable file of console application; 

 Input - specifies types of input data; 

 Output - specifies types of output data; 

 Options - sets up command line options. 
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 System section 

 Task Name field contains the current task name. It can be changed. 

 ID - task identifier. 

 Program - template name. 

 exe section 

 Exe File - path to application executable file. 

 Quote Type - rules for command line quoting (depends on compiler). It is 

necessary to specify if properties can contain nonstandard or punctuation 

characters. 

 Run exe destination - work directory of application executable file. There are 

two variants: Auto - MolQuest chooses work directory; or Exe path - work 

directory is set to location of exe file. 

 Debug Log File - name for MolQuest debug file, which contains the executed 

command line and other information about the application. Data in that file can 

be useful for troubleshooting and testing program integration. 

Common rules for editing the application options: 

As for MolQuest's own tasks, "Input files" can be single or multiple files and can be 

specified by user or taken from a pipeline, and output files can be sent to another task 

via pipeline. 

To activate a property, the appropriate box should be checked ( ). 

To prevent property from being displayed (e.g. a property that doesn't change its value 

in all conceivable task variants), right-click on it and choose "SubNodes - 

Permanently Hide" command from contextual menu. 
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The item becomes invisible, but its value is sent to a command line if that property is 

active. 
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Property name can be changed using "Property Rename" command from contextual 

menu. 

 Input section 

To define program input, two subsections: XX.Option and XX.Input shall be filled. 

01 Option - describes the way to specify input file name in command line: 

 Order - position number of this option in command line. By default, 0. 

 Key - prefix for current option. 

 Space - "no" means no space between prefix and value, otherwise - "yes". 

01 Input. Choose appropriate type of input data from drop-down list: 

 File - data will be taken from a file with user-specified path. Icon  means that 

file exists,  - path to file is wrong or file does not exist. 

 Files list - a list consisting of one or more files created in File List dialog 

(evoked by pressing  button) is used as an input. In such case MolQuest runs 

several passes, one file from a list at a time, in the same order they appear in a 

dialog window, until all files are processed. Results of each pass are shown in a 

list in Results Tab. Icon  indicates that file list is empty, while  means that 

it is not. 
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In File List dialog (see picture below), pressing  button opens standard Add 

File window, which is used to add files to a list. 

 

 

Order of files in a list can be changed by using  and  buttons. 
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To remove an individual file from a list, press  button, and to remove all 

files,  button. 

 Pipe - input data are taken directly from output of another task in the same 

project. Correct link to pipe data source is indicated by icon  ,while 

undefined or wrong link - by icon  . Similarly,  icon means that 

destination for output data is correct, and the  - that link is not defined or 

incorrect. 

To choose the link for input data, use  button (Placed on In Slots page), which 

displays "Select Task Output" dialog with list of outputs of task within current project. 

Moving outputs between "Available pipes" and "Selected pipes" lists is performing by 

mouse doube-click. 

 
 

file:///C:/Program%20Files/Softberry/Molquest2/help/gui/Templates.html%23InSlots%23InSlots
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 Output section 

To define an output file, two subsections: XX.Option and XX.Output should be filled. 

01 Option - describes the way to specify the output file name in a command 

line: 

 Order - position number of this option in command line. By default, 0. 

 Key - prefix for current option. 

 Space - "no" means no space between prefix and value, otherwise - "yes". 

 Type - from a drop down menu, select how an output is treated: as data, as 

warning messages, or as error messages. 

01 Output. Choose output type from drop down menu: 

 File - output file with specified name will be generated in the task-specific 

folder. 

 Pipe - output file will be sent to an appropriate pipeline. Icon  icon means 

that output means that output data destination is correct, the  that link is not 

defined or wrong. 

STDOUT.Options 

 Type - select in the drop down menu how the application standard output is 

treated: as data, as warning messages or as error messages. 

STDOUT.Output. Choose type of output data from drop down list: 



 

 

83 

 

 File output file with specified name will be generated in the task-specific 

folder. 

 Pipe - output file will be sent to an appropriate pipeline. Icon  icon means 

that output means that output data destination is correct, the  that link is not 

defined or wrong. 

If STDOUT subsections are not set, but a program outputs data to standard output, it 

would generate a warning. 

STDERR.Options 

 Type - select in the drop down menu how the application standard output is 

treated: as data, as warning messages or as error messages. 

STDERR.Output. Choose type of output data from drop down list: 

 File output file with specified name will be generated in the task-specific 

folder. 

 Pipe - output file will be sent to an appropriate pipeline. Icon  icon means 

that output means that output data destination is correct, the  that link is not 

defined or wrong. 

If STDERR subsections are not set, but a program outputs data there, it would 

generate a warning. 

 Options section 

To define an option, two subsections: XX.Option and XX.Value should be filled. 

01 Option - describes the way to specify an option in command line: 

 Order - position number of this option in command line. Default value is 0. 

 Key - prefix for current option. 

 Space - "no" means no space between prefix and value, otherwise - "yes". 

01 Value. Choose an appropriate type of option data: 

 String 

 Integer 

 Real 

 Char 

Once selection is done, all unused subnodes can be hidden. To do so, use "SubNodes 

Permanently Hide" command from contextual menu. 

Once all properties have been specified, the task can be added to repository 

(Repository tab) for further use in various projects. 


